0

I have an external hard drive Transcend ST2000LM003 2Tb USB3.0. I am already using it for 1 year. Everything was ok when I was using it plugged in to PC via USB2.0. When I used it on another PC plugging it via USB3.0, it has started to periodically (each 2-3 hours) hang over for exactly 1 minute. Firstly I thought that it was happening on one PC, but recently I have tried some other PCs and I am having the same problem (note there are no hang overs when used USB2.0). I tried to update the USB3.0 driver but it didnt help. The OS I am using everywhere is Windows 7. Please help me to solve the problem.

4
  • It sounds like the USB interface on the drive might be bad. Is it still under warranty?
    – Keltari
    Commented Nov 19, 2015 at 4:35
  • @Keltari nope, it has expired one or two month ago. is there a way to fix it independently? Commented Nov 19, 2015 at 4:43
  • Take the drive out and test it. If it works, just buy a USB drive enclosure. If it doesnt, throw it out.
    – Keltari
    Commented Nov 19, 2015 at 5:08
  • 1
    I'd strongly recommend you to try using a different USB 3.0 cable with the external HDD before taking it out of the enclosure. You might be dealing with a faulty cable, which could potentially cause such lagging/hanging from time to time. If that doesn't help, try using a SATA-to-USB 3.0 cable and see if the connectivity improves. I'd also suggest you to make sure that you update the 3.0 USB hub drivers from the official motherboard manufacturer's website, rather than Windows Updates. Best of luck! Hope I was helpful. :) Commented Nov 19, 2015 at 10:21

0

You must log in to answer this question.

Browse other questions tagged .