1

I notice that every now and then, especially when Windows updates were installed, my mouse, keyboard and NIC regain the ability to wake up the computer. This happend the last time when the "big" Windows 10 update in November 2015 was released. I wonder why.

Background: normally, I do not want that mouse movement or pressing a key on my keyboard wakes up my computer from hibernation, so I disable all wake events in device manager in the Energy settings of every device. If a device can be used to wake up the computer, it can be disabled here, and that's what I keep doing all the time. You can check which devices currently can wake up the computer using the following commandline:

powercfg -devicequery wake_armed

What I notice since Windows 7, and now again under Windows 10 is, that no matter if you disable the devices, certain updates seem to reset that behaviour. I normally notice that the settings have changed again when I hibernate my computer, and accidentally moving the mouse wakes it up.

I hate that behaviour, so how can I permanently switch it off, and why is Microsoft not capable of remembering these settings permanently, even when updates are installed? Does anybody know which updates exactly reset that behaviour? Just for your interest, after the November 2015 Windows 10 update, my Realtek network card, as well as my Logitech cordless mouse and my Microsoft Wired Desktop keyboard were wake-armed again, which is definitely unwanted :(

0

Every "big" Windows 10 updates Windows reinstalling all device drivers, they are copied from previous install, installed but with their settings reset to defaults. It's by design and probably done to decrease number of problems after upgrade. Just set it up again after every "big" update.

1
  • I understand your arguments, but in my eyes its poorly implemented by Microsoft. Energy settings are user settings as well, and should be preserves, like all other user settings like desktop background etc. are – Erik Dec 4 '15 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.