1

I use a USB to RS232 adapter to connect to routers and switches at work. Sometimes after little use the mouse goes wild and clicks uncontrollably, moustly mouse1 but mouse2 aswell. When at worst it clicks every 100ms. It can also jump two-three centimeters or so.

  • Hardware: HP Z-Book G2
  • USB to RS232: Aten UC-232A
  • External mouse: Logitech M310 with usb nano receiver
  • Windows 10

I have tried default drivers from windows 10 and also windows 7 drivers, but now using latest driver from Aten site. Tried reinstalling Windows 10 clean. No success. It doesn't seem to matter if I have connected and synced the external mouse or not. It seems to me that the USB2Serial adapter is triggering this behavior.

What solves this problem is to reboot, sometimes two(!) reboots are required.

This is what the problem looks like https://www.youtube.com/watch?v=1Ug3i9TLoBE

Hints?

5
  • Please describe how a "mouse goes wild". Or are you referring to the (mis)behavior of the cursor on the screen?
    – sawdust
    Commented Nov 19, 2015 at 9:50
  • Try using different USB ports.
    – sawdust
    Commented Nov 19, 2015 at 9:52
  • As described, it clicks uncontrollably. Mostly mouse1, but also mosue2 (which copy and pastes text in terminal wich can have terrible consequenses on the network equipment...) It clicks every 100ms at most or so, or every second when it starts. Using another USB port doesnt help.
    – OlofL
    Commented Nov 19, 2015 at 11:15
  • sealevel.com/support/article/AA-00487/0/… this link describes a fix for a similar problem. my driver don't allow me to change serial enumerator though. saw this aswell stackoverflow.com/questions/9226082/… will see if this helps. I see no serial-mouse or similar in device manager though
    – OlofL
    Commented Nov 19, 2015 at 12:39
  • This is what the problem looked like. youtube.com/watch?v=1Ug3i9TLoBE HP support changed my laptop keyboard and mouse. That didn't help. The solution for HP was then to change motherboard and problem was gone...
    – OlofL
    Commented May 3, 2017 at 8:00

2 Answers 2

0

Probably Windows detects serial mouse signals on the USB to RS232 adapter. Please see StackOverflow answer for a solution.

3
  • can you give more information the link might change
    – Sam
    Commented May 3, 2017 at 8:44
  • See my last comment yesterday on main post. I dont know how to mark something as solved though.
    – OlofL
    Commented May 4, 2017 at 9:12
  • USB devices have vendor and product id's. Possibly even borrowed ones. If the device was intended to go between a legacy serial HID, then the PC will treat it as such. The drivers it uses are based upon what it thinks it is. Find an alternative.
    – mckenzm
    Commented Nov 9, 2018 at 5:12
0

This was due to a bad motherboard.

They first changed the keyboard and touchpad, but no change. Later changed motherboard and problem was solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .