2

I'm running a Linux VM on windows with Hyper-V and connect via a remote desktop session. It often happens that the Alt-key appears to remain pressed after I use a keyboard shortcut involving both, Alt and Shift. If I press Alt again, everything works fine but it is pretty annoying because various keyboard shortcuts are triggered when I continue typing without pressing Alt again after the initial shortcut that causes the problem.

The problem is not related to a specific application but is reproducible in different apps.

I'm using the xfce desktop and xrdp.

  • I know this is an old question, but did you ever solve it? I'm running into the same exact thing myself: whenever I press Alt+Shift, the Alt key gets stuck "on", so that all keypresses are effectively Alt+{whatever}, until I hit Alt again. (For reference, I'm using centos 7, Gnome Shell, tigervnc-server, xrdp, and Remote Desktop Connection on Windows 7.) – Ken Bellows Jul 25 '18 at 14:51
  • 1
    @KenBellows no, at least I don't remember. Fortunately, I don't have to work on a windows machine anymore ;-) – lex82 Jul 25 '18 at 15:08
0

It is possible that you have sticky keys on. Pressing shift 5 times turns it on. Uncheck the setting on this pageenter image description here.

  • Unfortunately this is not the problem. It's turned off as in your screenshot. – lex82 Nov 19 '15 at 10:36
  • @lex82, it may not be your problem, but in my screenshot it is on. "Turn on Sticky Keys when Shift is pressed five times" is actually ticked. – Rohit Gupta Nov 19 '15 at 10:38
  • I thought the first checkbox would override it because of the indentation but I had also tried deactivating all of the boxes. – lex82 Nov 19 '15 at 11:20
  • No, try it. Press shift 5 times. – Rohit Gupta Nov 19 '15 at 23:02
  • Ok, you are right. However, unfortunately it does not solve the problem. – lex82 Nov 20 '15 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.