0

I have a small embedded system (Advantech MIO-5721) that I am working on that needs to be able to reduce its brightness for power saving reasons. The LCD (Mitsubishi Electric AA084XE01) is connected by LVDS with separate Inverter Power Output connection providing the backlights power.

Originally the system had Debian 3.2.68 running on it. I tried several approaches to this such as xbacklight but the folder /sys/class/backlight is empty so it fails with No outputs have backlight property. Also when I searched for any other folders containing "backlight" I go almost nothing back.

$sudo find / -type d -iname \*backlight\*
/lib/modules/3.2.0-4-686-pae/kernel/drivers/video/backlight
/sys/class/backlight
/usr/share/doc/xbacklight

When I run xrandr with no parameters to detect displays I get the following.

$xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*

I tried updating and rebuilding my kernel as well as trying different parameters for acpi_backlight= in my menu.lst file.

I next tried wiping the drive and starting over with a different distribution (Tiny Core Linux) with Xorg-7.7 in place of Xversa. The result is the same as with Debian where there is No outputs have backlight property for xbacklight. This lead me to think the issue is related to the board and its interaction with the monitor?

Looking on Advantech's website I found drivers for the board that were windows specific, so I wiped again and installed windows 10. I tried many combinations of drivers and software api but the brightness wouldn't change. I even tried following directions to change the brightness from command prompt. I was able to confirm that the stored brightness value was in fact changing, but the screen was not changing its brightness.

Ultimately I need a solution that will work on linux (probably a small version of Debian) but would be thrilled to see the brightness change at all at this point. Thanks a bunch for any help!

Update 11/23: I installed Windows 7 to test the drivers from Advantech again and I was able to adjust the brightness! Unfortunately the drivers appear to be Windows only. I am now in contact with Advantech regarding a Linux version of the drivers.

0

The issue was a missing driver. After being in contact with advantech they had drivers built for both 32 and 64 bit Ubuntu which were not on their website. The Ubuntu drivers (of the correct architecture) work on Debian enabling brightness control.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.