1

I'm having a weird problem with my computer (windows 10 desktop) where none of my browsers are able to access Google related websites. pinging google.com gets a timeout. I've tried reseting, clearing cache/cookies.

Every other site loads quickly as always. Does anyone have any idea what's going on? There are a few similar posts on superuser but I haven't seen the solution on them.

Other devices on the same wifi network have no problem

8
  • Try to change your DNS to google servers and if that doesn't help then check your firewall. – Mohi Nov 20 '15 at 5:43
  • 1
    @Insane I think it's 8.8.8.8 and 8.8.4.4 – Mohi Nov 20 '15 at 5:56
  • 1
    Isn't it 8.8.8.8 and 8.8.4.4 @Insane? – Leathe Nov 20 '15 at 5:56
  • Yessssss, typo. – Insane Nov 20 '15 at 6:16
  • changing the preferred DNS and alt to 8.8.8.8 and 8.8.4.4 didn't work. – Wil Han Nov 20 '15 at 6:47
2

This sounds like a fun problem to try and solve, so I might commit some effort into answering it.


Host File

I really doubt this could be a potential issue but the first thing you should do is perform the following commands:

nslookup google.com && tracert -d google.com

This should give you ample responses to what it resolves to and you should be able to see the routing. If you are unsure if the routing is correct try:

route print XXX

Where X can be GOOGLE.COM or an IP it resolves to. If all looks well here jump into your host file. You can open it by running the following command:

start notepad.exe C:\Windows\System32\drivers\etc\HOSTS

This can then identify if you have any weird entries for Google (or google services).

Lastly. jump on your home modem/router/gateway (whatever you call it) - usually via http://192.168.0.1

You can determine this by performing:

ipconfig | findstr /i "Gateway"

So just jump on and see what the DNS server is and if there are any odd blocks etc. for the services.

NICS with DNS

If you cannot iscolate the issue with routing or your host file, you should move onto the NICS. Jump back into CMD (or powershell) and run:

netsh interface show interface

Are there any weird adapters (virtual, VPN adapters) etc. enabled? Try disabling any you are not using:

netsh interface set interface "network adapter name" admin=disable

Jump into your network adapter (via Control Panel\Network and Internet\Network Connections) and open the properties. Ensure that there are no weird IP address or DNS settings listed (if you are static screenshot them before setting them to static).

Whilst you're here, add Google DNS as a backup. Under the NIC go to Advanced, DNS and add 8.8.8.8 and 8.8.4.4 for failover. Once done open a CMD screen and run the following:

ipconfig/release && ipconfig/renew && ipconfig/flushdns

Ensure you have a correct IP address and then re perform the NSLOOKUP and TRACERT and see if it is any different.

Now a word of advise..Google will reject you if your Date and Time is in the past, or drastically in the future.

Add-Ons

The first thing you need to check is your Google Chrome Add-Ons. Have you got some add-on that blocks all http requests, such as HTTPS everywhere? Try to run IE or Google Chrome in Incognito Node. Open Chrome and hit Ctrl + Shift + N- can you get to Google?

See if you can load the Google-Diagnostic tool via the following link:

https://chrome.google.com/webstore/category/extensions?hl=en-US

Additional Tools

Try loading an application like Fiddler and Wireshark to do some packet captures. If you know what you're doing you can do the following:

start chrome.exe https://plus.google.com && netstat -n -o 1

Try to identify what packets are not getting there. You can perform an NSLOOKUP of the packets that are having trouble, e.g.:

nslookup 124.125.66.65

you may notice some weird ad server trying to get in before you get to Google. Oh, and try to do a virus scan and make sure there are no weird process running; perform a msconfig also to make sure nothing weird starts on startup.

I have seen some weird issues where start chrome.exe https://plus.google.com does not work because of an add-on but start explorer.exe https://plus.google.com works fine.

Hope this is a good starting point. Get back to me and I will follow up :)

1
  • 1
    Thank you so much for the reply! For some reason, after almost a whole week of not being able to access gmail or youtube, it started working normally once I got home from work today (was still broken when I went to sleep the night before). I'm pretty baffled as to what happened and am wondering if it was something up with my ISP. I've seen quite a few people ask this question with no answer while googling around so hopefully your answer helps other people looking. I used to use https everywhere but it wasn't around for this, and I disabled every extension while trying to solve it. – Wil Han Nov 21 '15 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.