1

I have Lenovo W530 with Windows 8.1, and it has that annoying feature which changes contrast depending on colors of application (both on battery and AC). I've found that this is quite common on Intel display card, but I use nVidia Quadro K2000M. I have every possible option for power saving turned off, and it still does it.

For example:

  • Display brightness: 100%,
  • Dimmed display brightness: 100%,
  • Enable adaptive brightness: Off.

In addition system, drivers and BIOS are up to date.

Any idea what else can I try?

  • Could you add where the in the menu's you turned off adaptive brightness? There might be multiple options. – BramMooij Nov 20 '15 at 11:04
  • It was in Power Options | Advanced settings – Krzysztof Nov 20 '15 at 12:06
  • Thanks. Do you have Intel graphics as well? If so, could you check if the problem persists after you force your system to use the Intel graphics? (You can set this in the BIOS) – BramMooij Nov 20 '15 at 12:14
1

Did you try disabling automatic brightnes in the Windows 8.1 Metro settings?

enter image description here

Else you can try disabling the 'Sensor Monitoring Service' in windows services. Though by disabling the service, the rest of the sensors will also be disabled. (accelerometer, gyro, etc.)

This can be done by following these steps:

1. Press Win+R key combo
2. Type and run: services.msc
3. Find “Sensor Monitoring Service”
4. Right click and select properties
5. Select “disable” under “startup type”
6. Finally reboot your computer.

Let me know if this solves it for you.

  • I don't have Brightness box in metro settings, also Sensor Monitoring Service is already disabled. – Krzysztof Nov 20 '15 at 12:07
  • Do you have any auto-brightness settings in the NVIDIA control panel? Try checking there, and disable if present. – Smeerpijp Nov 20 '15 at 12:09
0

I have found two possible options, the first one of which would be the preferred option.

Open the Nvidia Control Panel:
- go to Adjust Video Color Settings
- check: With Nvidia Settings
- go to the advanced tab and click: use full dynamic range
- disable dynamic contrast enhancement

enter image description here

If that doesn't work, I found a Dutch topic covering the same issue. The solution was to install old nvidia drivers.

This is an old driver: http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS029984 Another one: http://drivers.softpedia.com/get/GRAPHICS-BOARD/NVIDIA/Lenovo-ThinkPad-W530-NVIDIA-Intel-Graphics-Driver-918131100-815102725-for-Windows-7-x64.shtml#download

If that doesn't work. Possibly try this link, it's a Dell driver, but it might work for you as well: http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=HDFR9 Even older driver: http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=95K0T

Solution 1 source: https://rog.asus.com/forum/showthread.php?38038-Autobrightness-based-on-lightness-of-items-on-screen
Solution 2 source: http://gathering.tweakers.net/forum/list_message/45300398#45300398

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.