7

My Firefox install on my desktop is repeatedly trying to connect to "https://incoming.telemetry.mozilla.org". That site appears like it's probably legit (my only question is that it appears to be hosted on AWS, but I suppose it's possible Mozilla uses them). The problem is that those IP addresses are blacklisted through our corporate AV/AM vendor. The end result is that I'm generating security alerts all day long...

While I could escalate this with the vendor, I'd like to just kill the telemetry in Firefox anyways for privacy reasons. Unfortunately, I can't seem to find a telemetry option in the settings screens and Google is failing me too.

10

If you go to Tools -> Options -> Advanced -> Data Choices you can untick the the options there. Firefox telemetry location

1
  • 1
    Ah, excellent. The lack of the telemetry keyword was enough for me to totally miss those options! Nov 20 '15 at 14:19
3

Or... go to about:config in Firefox and search for "telemetry" and set toolkit.telemetry.server to 0.0.0.0, or some other non-existent IP. Also be sure to disable toolkit.telemetry.unified, toolkit.telemetry.enabled and toolkit.telemetry.archive.enabled. When I say disable a setting, I mean set it to False.

Enjoy assurance you're not being spied on by companies! Except if you use Windows 10...

1
  • See also this post on the support forum.
    – GDP2
    Apr 5 '18 at 0:21
0

In the meantime (Firefox 90 is the current version at this point in time) these settings have moved to Settings -> Privacy & Security -> Firefox Data Collection and Use.

Alternatively you can reach these settings by entering about:preferences#privacy in the URL bar.

Screenshot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.