1

After my PC crashed apparently due to a corrupted RAM module (scanned my RAM after the crash while trying to find out what went wrong and tons of errors came out) I now seem to have a locked / corrupted SSD drive (my primary windows drive).

The disk will not boot anymore. I tried to boot from my windows installation USB to try and fix the problem without success. Trying to fix the disk will prompt an error that the disk is locked. Trying to access via command prompt won't work (error that I get: The disk structure is corrupted and unreadable), and chkdsk c: /f will also return with an error (Windows cannot recover master file table. Check disk aborted.)

I have now booted in Linux Mint, trying to figure out a way to at least see if I can access the drive from there to backup some files, but this will not work either (please see screenshot attachment). If anyone has any idea what I could do to fix this problem, it would be really of great help. Thanks.

(Note: the problem is with drive sda1)

enter image description here

* **Edits ***

As this problem seems to be haunting many, as I have found allot of scattered information on the web. I will update the question with my attempts (all failed to far), since there seem to be quite a number of options someone can try and one or the other may be able to help someone else.

Things tried so far: - Boot from windows 8 USB installation disk, and tried to repair my drive with the available tools (failed for me) - Used command prompt and chkdsk c: /f as suggested by many (also failed) - Booted Linux via USB and tried some options there, such as: TestDisk app, ntfsprogs / ntfsfix (all failed)

migrated from serverfault.com Nov 21 '15 at 20:55

This question came from our site for system and network administrators.

1

Check TestDisk and PhotoRec if you want to recover files from that partition.

  • Unfortunately it does not help. $MFT and $MFTMirr do not match, and TestDisk cannot fix them, so I get an error (The file system is damaged and it cannot access the files on the disk.). I have been looking for a solution for hours now without success, ntfsfix under linux does not work either (I/O error). It seems that I will have to try a commercial recovery tool such as the ones suggested on TestDisk's documentation. – Spiros Nov 21 '15 at 23:10
1

The first thing I would do is get clonezilla and copy the bad disk... just in case. I believe that clonezilla also has some disk repair options. You say it's a windows drive? Then it's not exfat it's NTFS Something to keep in your back pocket (if the data is worth it) is the software SpinRite. It is 80$ but worth it. I'd wager SpinRite would fix it in a heart beat.

  • I always had in mind that windows 8 uses ExFAT for flash / SSD drives, or am I mistaken? To be honest, I am a bit confused at the moment, because I had the impression this is the case. From what I see now it may as well not be. I will change the question title. – Spiros Nov 21 '15 at 21:15
0

Unfortunately I found no solution to this problem. I have tried a commercial recovery tool as well as TestDisk. The commercial tool found files, but everything was scattered and there was no structure in the results, which in my case was completely useless since we are talking about source code files. So, in the end I formatted the disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.