A little background - I have a Lenevo G50 which was running Windows 8.1 up until a few months back. Then came along the free upgrade to Windows 10. Microsoft updated the laptop OS to windows 10, and all was fine in the first run. But, as soon as I shut the laptop down, and powered it back up the next time, it just would not connect to the same wifi. This situation continues until today. Everytime it's the same message - "Can't connect to this network".

The only way I got around this until now, was to manually reboot the wifi router, and as soon as the router would come back up, Windows 10 would instantly get connected. I have no idea how/why this worked, but while it did work fine up until sometime back, I can't keep doing this anymore. I share my apartment with a few other guys, and having to disrupt their internet connectivity every single time I turn on my laptop - is not just a minor convenience anymore (not that they haven't voiced their concerns over this, anyway).

I looked at this No internet connection after upgrade to Windows 10 question, and tried to check my "advanced adapter options", but it all seemed correct (attaching pictures below).

Getting Connected - step 1 The error message - step 2 adapter settings - step 3

I would really appreciate any help if anyone has faced this issue.


I should have mentioned this along with the original post, but all other devices [Macbook Air, Macbook Pro, iPhones, iPads, Windows 8.1(running on a Dell and an HP)] connected to the same wifi in this apartment, work just fine.

  • What security is the router using? Have you updated your network adapter drivers? Can you connect to wireless using other devices? Are you using a static IP? We're going to need more info. – Bilfred Nov 22 '15 at 7:21
  • I'm sorry about that! I've added info about other devices, if you could tell me where to look for the rest of the info you asked for - it'll be much faster. – Manish Giri Nov 22 '15 at 7:28
  • I have a similar issue. Pls see superuser.com/questions/1023244/… – kp91 Jan 18 '16 at 14:39
  • 3
    You can look at some of the logs for wifi by running: logman update wifisession -ets && netsh trace convert \windows\system32\logfiles\wmi\wifi.etl – Nick Banks Apr 20 '16 at 20:37
  • I've also issue with wifi, Only one of AP is not connect on windows 10, How could you solved it? – Nullpointer Jul 27 '16 at 8:43

11 Answers 11


I had the below issue Windows 10 wifi issue: “Can't connect to this network” while every other wireless devices worked, this newly upgraded Windows 10 Did not.

The below helped: In Device Manager, Right Click on Device > Properties > Advanced and I disabled 802.11n Mode, it may slower on actual Wireless N networks, it resolved the problem for the time being.

enter image description here

  • I've same issue, Only one of wifi is not able to connect on w10, How can you solved it? – Nullpointer Jul 27 '16 at 8:46
  • 1
    This solved it for me. Why does this make connecting to certain wireless networks work? (specifically a PEAP authenticated WPA2 Network for me). I didn't have this problem Windows 7. – Bryce Guinta Nov 17 '16 at 23:41
  • This worked for me too +1 - but it’s a workaround – DarkHeart Jan 25 '19 at 8:20

Found even after a reboot "can't connect to this network" error. To resolve: open Device Manager (devmgmt.msc), locate the wireless network adapter, disable and then re-enable. Wireless connected back up immediately after doing so.

  • Same here, tried every suggestion from every answer and this worked. Additionally tried connecting to a different network that didn't work so it was an adapter problem, not a network issue. – Vladimir Bozic Aug 8 '17 at 21:05

log into your router and change the network name. I have fixed this issue on multiple laptops by doing this. It seems to simple, and like this should have no bearing on connectivity but it does. Hope this helps.

  • This was the only thing that worked for me. I had two Windows 10 machines do this inexplicably on the same day. No windows update in history (though it was on a patch Tuesday). I tried restarting router & PC, disabling/enabling the WiFi device, re-installing drivers, forgetting network, etc. All other devices worked fine. The only thing that worked was changing the damned SSID. :/ – Nick Oct 11 '17 at 19:15
  • 1
    any idea why this works? It worked once for me, but not anymore. Other than the simple "forget network" command which only seems to forget the password, is there another way to delete all details of a network from Windows 10? – LShaver Jul 1 '18 at 3:20
  • 1
    +1, I can't believe this worked! Same as Nick, I tried everything in the book. I even uninstalled the WiFi adapter, deleted registry entries, disabled or uninstalled all antivirus/firewall/VPN software, mucked around with all the obscure adapter settings. Nothing budged. My adapter always quickly switched to disabled when trying to connect, then re-enabled but failed to connect. – adabyron Dec 4 '18 at 10:49

I can see your Wi-Fi adapter is a Qualcomm Atheros AR956x card - the drivers for which are here. Download and install the latest drivers. To find if you have a static IP, when looking at "Wi-Fi Properties", as in your screenie above, click on "Internet Protocol Version 4 (TCP/IPv4)", and then click on the "Properties" button for it. If you have a static IP, there'll be a selection of numbers in the format of "##.##.##.##" in the text boxes. If not, then you don't have a static IP and everything should be OK in that department.

Hopefully, the driver update should fix it as I have seen articles of people with the same adapter not being able to connect to wireless, but after updating are able to connect.

  • Sorry it took a while for me to update this. I can confirm I don't have a static IP. And as for the drivers, I downloaded the latest one. There were 6 files downloaded in total - 3 were athwb and the other 3 were athwbx. Each of the 3 files were - Security Catalog, Setup Information and System File. Only the setup information file had an option to Install on right click. I did the install, but it didn't look like anything happened. The same issue continues today. – Manish Giri Dec 4 '15 at 11:09

Have you done the upgrade or fresh install?

Try removing the network from your list of saved networks and add again.

If that fails, remove the driver for your network card and reinstall.

If that fails, try adding the network manually.


I had the below issue Windows 10 wifi issue: “Can't connect to this network”

The below helped: In Device Manager, Right Click on Device > Update Driver > Browse My Computer for Driver Software > Let me Pick from a list of device > Uncheck Show Compatible Hardware > Select Appropriate driver

Retry and it works (no reboot required)

  • This one worked for me. I didn't uncheck Show Compatible, but selected Microsoft's driver for Intel(R) Dual Band Wireless-AC 8260. This is on a Lenovo P50. – Thomas Eyde Mar 22 '18 at 20:48

netsh winsock reset did the trick for me.


I have the same problem with the same network adapter. I don't know how to get ANY relevant information. Roll back and uninstalling driver didn't help.

The network configuration didn't change as well. The only thing that did change was I've upgraded .. wait for it... qualcomm atheros AR9462 bluetooth 4.0 driver to newer version.

Unfortunatly removing this driver didn't resolve my problem.

EDIT: For me it helped to reset router (just unplug and plug it again)

  • I don't see any way out of it, yet. To this day, I have to unplug and replug the router to get the internet working. This is really getting annoying now. – Manish Giri Dec 24 '15 at 23:11
  • I think it might be an issue with router. I've plugged another router (old one I've found when tidying thigs up) and set it up exacly as first one (same network, ssid, security options and password) and it's working since then (two AP's with the same SSID, pass). Also it's in the same room as laptop is right now (previously it was a little further 3 out of 5 bars). – Marcin Konrad Ceglarek Dec 26 '15 at 0:07

I suddenly started getting this error without having changed anything. I tried everything I could think of on my PC, including forgetting the network, updating the driver, rebooting, etc but nothing worked.

I rebooted the router. That worked.


With a similar issue, I disconnected all my peripherals (headset, mouse, keyboard, and monitor) and it magically worked..

This is after trying most of the solutions listed here.


I tried uninstalling/installing, updating driver and none worked. The only successful solution was to choose Roll Back Driver from device properties.

Not the answer you're looking for? Browse other questions tagged or ask your own question.