0

My MacBook pro consistently takes hours to recognize a FAT32 (ms_dos) external hard drive. I have the same issue on a 2015 MacBook Air. The drive has 500G capacity and is connected via USB (no external power source.)

I did not have this problem on my old laptop, which ran Linux.

The drive contains 300GB of music and movies and 100GB of backups. It also contains a corpus of 13GB of 500B .doc file fragments (i.e. millions of files.) Could this be the problem? The file fragments were added sometime after I got my Mac. I can't recall if the problem started before or after.

Right now, I am executing du -depth 1 to get an overview of the disk usage of each folder, but it takes ages to complete. I'm thinking this is another symptom of the same problem.

0

I solved it by backing up the most important files, and reformatting the disk.

Initially, I tried removing the problematic folders, but that also took ages.

Now, du runs in a couple of seconds, and the drive immediately mounts.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.