6

Generally, my copy/paste works just fine in vim.

However, when I type :version, my mouse pointer becomes a symbol like:

no, not allowed

While I can select text, I can't copy it to the clipboard.

Exactly the same behaviour with error output.

How do I disable this "feature"?

4

In that message output mode, copying with the mouse indeed isn't possible. Only a few paging commands are available there. So, that "feature" doesn't exist yet.

There are several ways to obtain the output. The most generic is via :redir, e.g. into the unnamed register:

:redir @"
:version
:redir END
:put

For a single (last) error message, you can also directly access this via v:errmsg:

:put =v:errmsg

In the terminal, you could also disable Vim's mouse integration via :set mouse=, and then use the terminal's mouse drag to copy the (visible) text.

  • You can make a single command in your vim rc: command! PutMessages redir @" | messages | redir END | put – Chiel ten Brinke Jun 9 '16 at 7:27
  • This doesn't seem to function in NeoVim/VimR, unless I misunderstand how it's supposed to be used? When invoking :PutMessages, the :messages are still just printed in red, not copied. (However, `:let @+=v:errmsg works for me; so I know my clipboard support is functioning!) – ELLIOTTCABLE Oct 10 '17 at 17:46
1

If you set the 'clipboard' option to autoselect Vim will automatically attempt to become the owner of the system's copy buffer. This will let you copy text in the situations you describe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.