2

I am using the latest Linux Mint and have tried many solutions, but I need a solution that is directly applicable to this problem.

All https:// have been removed to prevent spam.

W: Failed to fetch ppa.launchpad.net/shnatsel/zram/ubuntu/dists/trusty/main/source/Sources 404 Not Found

W: Failed to fetch ppa.launchpad.net/shnatsel/zram/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch ppa.launchpad.net/shnatsel/zram/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

3 Answers 3

3

I'll agree that you probably need to reset your software sources. If you need some help on how to do that, here are some instructions that should work for Linux Mint (and Ubuntu too, they're very silmiar).

Backup the sources.list files

Just copy them to a backup folder somewhere, this should work:

sudo cp /etc/apt/sources.list /etc/apt/sources.list.old
sudo cp -R /etc/apt/sources.list.d /etc/apt/sources.list.d.old

or put the copy in your home somewhere:

sudo cp -R /etc/apt/sources.list* /home/myuser/

Restoring the default sources.list & sources.list.d files

If you do this it should generate a new fresh sources.list file

  1. delete the old files:

    sudo rm /etc/apt/sources.list

    and

    sudo rm -R /etc/apt/sources.list.d

  2. Then Run "Software Sources" from the programs menu / dash, or in a terminal

    sudo software-sources

    and select/check-mark backports/romeo if desired, pick servers or keep the defaults, and update.

OR this is what a default Linux Mint 17.2 file should currently look like, with backported packages selected:

# Do not edit this file manually, use Software Sources instead.

deb http://packages.linuxmint.com rafaela main upstream import backport  #id:linuxmint_main
deb http://extra.linuxmint.com rafaela main #id:linuxmint_extra

deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner

Credit to one of my answers on AskUbuntu

2
  • Running software-sources gives me the error: OSError: [Errno 2] No such file or directory: '/etc/apt/sources.list.d' Which makes sense, since I deleted it, but software-sources does not create a new one? I am on 18.3
    – eddy147
    Mar 29, 2018 at 9:39
  • 1
    @eddy147 It used to work, back when I last tried it. Does recreating the empty directory then work ok? sudo mkdir /etc/apt/sources.list.d should do it
    – Xen2050
    Mar 30, 2018 at 0:34
1

All of the Linux Mint 17 releases - Quiana, Rebecca, Rafaela and Rosa - are based on Ubuntu 14.04 and packages compatible with Ubuntu 14.04 are not available from ppa:shnatsel/zram. That is why you are getting Failed to fetch ... 404 Not Found errors when trying to update your software.

To remove these errors you must remove ppa:shnatsel/zram from your software sources. Your software sources are determined by this file: /etc/apt/sources.list. The easiest way to edit the sources.list file is from the terminal in nano editor using the following command:

sudo nano /etc/apt/sources.list  

The instructions for using nano are always displayed at the bottom of the page. Use the keyboard combination Ctrl + O and after that press Enter to save the file to its current location. Use the keyboard combination Ctrl + X to exit nano.

1

I encountered the same problem (Linux Mint 18.1), but updating with the graphical update manager. In my case the "Failed to fetch ....404 Not Found" was solved when I went (in the graphical Update Manager) to Edit -> Software Sources -> Maintanence. There, click "Fix MergeList problems" and click on the "Update the cache" button. After this action I was able to update everything without errors.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .