How do I access my files visually from the Finder?

The drive is mounted, it is not empty, it worked on a Windows PC. And, as stated, I can access all of the files using the terminal.

A couple of notes:

  • The drive refuses to eject. Even if I force eject it from the terminal, the light on the external stays on.
  • The drive was verified through disk util to be okay, but then after playing with it for a while trying to fix this, disk util said to reformat the drive. It’s still working fine on other computers regardless.
  • It's formatted in exFAT. This drive has worked fine before.
  • I have permissions to read and write.

EDIT: I just left the Finder window for the drive open for ~20 minutes, and the files magically appeared. The last thing I did with the drive was unmount/remount using the Terminal. I checked right after I did that, and still no files. Yet, 20 minutes later, they're there.

Would anybody be able to provide an explanation in case this happens again? I feel as if this will happen again.

  • Please edit your question to add some details such as what version of Mac OS X you’re using and what version of Windows the drive works on. This is most likely a cross-platform formatting issue, but knowing the specifics might help. – Giacomo1968 Nov 23 '15 at 1:26

ExFat drives, in my experience, behave strangely under Mac OS X after they are improperly removed. Note that this applies to both user error (ie, you forgot to press the eject button beforehand) as well as software malfunctions (ie, your computer hard crashed while the drive was inserted).

Once the improperly-removed exfat drive is reconnected to a Mac, one of a couple things tend to happen to me:

  1. The drive simply does not appear in Finder. Disk Utility can see it, but will refuse to remount it. If you run first aid, Disk Utility will display a quite-scary message saying that the drive is broken beyond repair.
  2. The drive will mount and appear in Finder, but some or all files will not be visible in Finder and/or in the terminal. The terminal and Finder may give different results as to which files are visible.

In both cases, the problem can be fixed by simply leaving the drive connected to a Mac for somewhere between 10 minutes and three hours.

You can also plug the drive into a Windows machine and run Microsoft's disk repair utility, which will allow the drive to work properly when it's reinserted into a Mac but will usually cause some files to be permanently deleted.

I have no idea why this happens. Regardless, the solution is simple: leave the drive connected to a Mac for however long it needs to repair itself.

  • 1
    Thank you! Your ten minutes to three hours suggestion seems to be in line with the drive magically working after about 20 minutes. However, it stopped working once again, so I'll mark your answer as correct when I have 3 hours to spare. – underscore Nov 23 '15 at 1:12
  • Alright, it worked, thanks again. Is there a more reliable file system to use that's cross-platform that this doesn't happen with? – underscore Nov 23 '15 at 2:01
  • Damn, thanks. I ejected the drive successfully after the files showed up (finally), and plugged back in the external drive, and the files are gone again. Looks like I'm going to have to wait 20 minutes every time I plug in the drive. Or format to OSX filesystem. – underscore Nov 23 '15 at 2:11
  • If this is happening after the drive is properly removed, you may not be having the same problem I was describing. – Wowfunhappy Nov 23 '15 at 2:15
  • Well, regardless your solution is still working. The files have shown up again. I will probably just back up and reformat the drive. Thanks. – underscore Nov 23 '15 at 2:17

Could it be that the files are hidden? I had a similar problem and as I suspected, after deleting the files, they were moved to a hidden trash folder on the same drive.I followed the steps in the link

  • Open terminal and enter the following: defaults write com.apple.Finder AppleShowAllFiles NO
  • Relaunch finder by alt clicking the finder icon and click relaunch.



It's a faulty drive that is struggling - pretty self-explanatory, hence the intermittent behavior and the write/read delay. Formatting a drive makes no difference if the behavior is slow.

Hide&seek- the hard drive is literally telling you its dying - plug it in, backup data (when it finally shows) replace the drive.

  • 1
    This isn't a result from faulty drives. The issue occurs on macos, but the drive works fine in Windows. Even occurs with brand new drives that behave as expected. – monokrome Dec 22 '20 at 5:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.