1

I updated the DNS record for a certain website yesterday, but right now I'm facing an issue regarding my own computer's DNS cache, since I keep getting the old server's IP address when trying to access my site. Issuing ping or nslookup confirms that my DNS is not updated.

I am sure this is an issue with my computer, because I get the right IP address when using the router's ping tool, as well as my Android phone and a couple of virtual machines.

I've tried:

  • ipconfig /flushdns (from command prompt with admin rights)
  • Stopping and restarting the dnscache service
  • Restarting the computer
  • Zeroing the C:\Windows\System32\drivers\etc\hosts file
  • Manually setting the DNS server in my network adapter's properties to my ISP's DNS provider and also Google DNS and OpenDNS.

What is going on, and how can I fix this? I'm using Windows 10 64-bit.


Update: I deleted my virtual network switch from the Hyper-V manager and my DNS cache went back to normal.

Then I restarted the computer and created a new virtual switch, and this caused the old cache to take place again.

So I found the culprit, but not the solution - I do need the virtual switch to access the internet from my VMs.

| improve this question | | | | |
  • I think you meant to say nslookup instead of dnslookup. – boot13 Nov 24 '15 at 8:51
  • Try running ipconfig /registerdns on the machine thats getting the OLD ip address from an elevated command prompt. Run a ipconfig /flushdns from other machine to flush the dns cache with the wrong entry, finally try to ping the hostname again. – Smeerpijp Nov 24 '15 at 9:01
  • @doenoe I did that, still no success – Marc.2377 Nov 24 '15 at 9:20
  • It might be helpful to run Nirsoft's DNSQuerySniffer, which shows the details of all DNS queries. – boot13 Nov 24 '15 at 10:01
  • 1
    @boot13 Ah cool to know, indeed it appears that Nirsoft has a handy tool for everything! – Marc.2377 Nov 27 '15 at 15:03
0

As hinted in the update to the question, this was a bug in the network switch implemented by the Hyper-V stack (on host-side).

There appears to be no solution. Maybe, just maybe, "re-installing" Hyper-V could work. But I wouldn't count on it.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.