I recently needed an Ethernet adapter for my laptop, which has USB and WiFi (of course) but no Ethernet. Somebody offered me an Apple USB-to-Ethernet adapter. I figured Windows would offer the driver automatically, after which I could use the computer in places where only wired networks were available.

Well, I plugged it in, and no such luck! Windows 10 Enterprise x64 recognized the hardware, but said it couldn't find a driver for it. I tried searching online (connected over Wi-Fi), and found a bunch of people referencing this page by somebody using the alias “Tnkgrl.” Unfortunately, the DropBox download link is no longer pointing to anything! I also searched Apple’s site, but couldn’t find any Windows drivers: Maybe they’re included in Bootcamp but not available for download?.

Anybody know how to get this device working in Windows?

  • 1
    per a below answer: get the driver directly from Microsoft. MS has a newer driver than even the vendor's web site, and getting it straight from MS also avoids malware. To do that, search the Windows update catalog for ax88772 . see below answer for full link catalog.update.microsoft.com/Search.aspx?q=*ax88772* Oct 18, 2019 at 4:51

4 Answers 4


I did a little more hunting online and found this link to a blog that said they'd found the driver for the chipset in the adapter, and convinced it to work. I followed a variant on their instructions, and it worked for me too. Here are the steps I used:

  1. Plug in the adapter while the computer is running.
  2. Check Device Manager (you can get there by right-clicking Start). You should see a listed Apple device with a little yellow exclamation mark next to it, saying Windows can't load the driver.
  3. Go to the website listed in the blog post and find the driver for your OS. I used this one for 64-bit Windows 10. Note that this is the actual driver download, not a Setup program.
  4. Download the .ZIP file. If you use a browser that adds the "mark of the web" (IE or Edge for sure, maybe others), right-click the downloaded ZIP, go to Properties, click Unblock (either a button or checkbox), and hit OK.
  5. Unpack the ZIP archive. You should see a folder containing four files: a .SYS file (the driver), a .CAT file (the WHQL signature), a .INF file (the driver information), and a Readme.txt. Don't do anything with these files directly, but remember where they are.
  6. Go back to Device Manager, right-click the device entry that needs the driver, and choose Update Driver Software....
  7. Choose Browse my computer for driver software.
  8. Choose Let me pick from a list of device drivers on my computer.
  9. If there's a Have Disk... button in the lower right, click it. Otherwise, click the top entry in the list (should be something like "All devices") and hit OK, then click Have Disk... on the next screen.
  10. In the box labeled "Copy manufacturer's files from:", type in or browse to the location where you unpacked the .ZIP file, then hit OK.
  11. Choose the option ASIX AX88772A USB2.0 to Fast Ethernet Adapter (on my system, it is the second option listed). Hit Next.
  12. You will get an "Update Driver Warning" or similar saying that Windows can't verify that the driver will work with your hardware, which may cause problems. Click "Yes" anyhow, for this and any other prompts to confirm that you want to install the driver.
  13. You should now have a working Ethernet adapter! In Device Manager, it will be listed as a "ASIX AX88772A USB2.0 to Fast Ethernet Adapter" under the "Network adapters" category, and there should be no exclamation marks or anything like that.

There you go! You can connect to a wired network, and it should work fine. The original instructions were for Windows 8 x64, and I can verify that it works on Win10 x64; I haven't tested it on other versions but the same steps should work and the download site lists drivers for tons of operating systems.

  • 1
    Updated win10-64bit driver download link: asix.com.tw/FrootAttach/driver/…
    – Iraklis
    Jun 30, 2016 at 9:54
  • 1
    updated driver link again: asix.com.tw/download.php?sub=driverdetail&PItemID=136
    – Glogo
    Oct 26, 2016 at 13:46
  • 6
    In my case Windows already had required driver. So on 8 step I had only to select "Network adapter" device type, and then manufacturer "ASIX" and device "ASIX AX88772A USB 2.0 to Fast Ethernet adapter".
    – Torbins
    Mar 27, 2019 at 15:57
  • @Torbins Interesting! Which version of Windows was this? I didn't actually check to see if the chipset had a pre-installed driver that just was looking for a different PnP ID, but it also might have been added more recently.
    – CBHacking
    Mar 29, 2019 at 0:26
  • 2
    Updated link - asix.com.tw/en/support/download Apr 27, 2021 at 9:52

If you prefer to download the driver directly from Apple's site:

  1. Download the latest version of "Boot Camp Support Software" from Apple.com: http://support.apple.com/downloads/#macoscomponents
  2. Open the ZIP file and go into the BootCamp\Drivers\Asix driver
  3. Run the AsixSetup64.exe driver installer
  • 3
    FYI: you don't need to run the installer, you can just point to the .inf file in the driver wizard.
    – SaeX
    Jul 29, 2016 at 11:50
  • 2
    To expand on @SaeX's comment, the AsixSetup.exe file is a self-extracting archive, you can open it using 7-Zip or similar and then extract the .inf, .sys, and .cat files. Then you can just right-click the .inf file and select Install.
    – CBHacking
    Apr 9, 2018 at 20:00
  • This did work for me and not the other method from above by CBHacking which I tried before. I used the Boot Camp Support Software 5.1.5769 ZIP. And then the ASIX Folder, extracted the AsixSetup64.exe with 7-zip and pointed the device manager update drivers dialog to the exctrated location. Done - first try.
    – Paxsali
    Jun 10, 2019 at 13:20
  • Actually, both methods work, just BootCamp method is more straightforward and painless.
    – AnrDaemon
    Oct 18, 2019 at 16:39
  • This was the only method that worked for me with Windows 10 Insiders Edition - the chosen answer was never able to recognise the Windows cab file drivers. Nov 3, 2021 at 3:25

From Microsoft

search the windows update catalog Windows update catalog for ax88772

and get the driver from them.

Download the cab, extract it and install it using the device manager. It doesn't matter which "name" you select - you get an warning that the driver will not fit - but they all work.

From Apple

Download the update catalog file using the official links:


eg. https://swscan.apple.com/content/catalogs/others/index-10.13seed-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

Extract the xml file and open it in notepad++

Search for "BootCampESD.pkg" (CTRL+F) and you will find many of them.

In the search result window double click the latest one and download the full url to the BootCampESD.pkg

As of writing the newest one was: http://swcdn.apple.com/content/downloads/41/17/091-14331/br9prfd71k86fkwgx421ept2s931s0bv2p/BootCampESD.pkg

Extract the *.pkg using 7-Zip: BootCampESD.pkg\Payload~.\Library\Application Support\BootCamp\WindowsSupport.dmg

Extract the *.dmg also with 7-zip: WindowsSupport.dmg\BootCamp\Drivers\Asix\AsixSetup64.exe

Extract the *.exe (rarsfx) again with 7-zip and you get the plain driver:

; Apple USB Ethernet Adapter 
; Copyright 2007-2010, Apple Inc.
; Version:        for Windows Vista 64-bit
Signature  = "$Windows NT$"
CatalogFile = AppleUSBEthernetex.cat
Class      = Net
ClassGUID  = {4d36e972-e325-11ce-bfc1-08002be10318}
Provider   = %APPLE%
DriverVer = 02/01/2008,

%APPLE%   = USB, NTamd64

ExcludeFromSelect = USB\VID_05AC&PID_1402

%AppleUSBEthernet.DeviceDesc% = AppleUSBEthernet.Ndi,USB\VID_05AC&PID_1402

And yes, it still works also on Windows 10 x64


I have extracted the drivers form the 263MB "Boot Camp Support Software": http://kom.aau.dk/~pmr/www/stuff/AsixSetup64.zip

EDIT: Link not working anymore, below USB_Ethernet_Drivers 239KB link: https://docs.google.com/uc?export=download&id=1RHiz49_6bH5trdiu_7rJJgx8Tfo7g5kN

  • 8
    Welcome to Super User. Note that there were already two answers providing a source, including a link directly to Apple. It was considerate of you to post another source, but realistically, people aren't likely to download unknown files from a user with no history on the site when there is an official link available.
    – fixer1234
    Jul 20, 2016 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .