4

I have trouble setting up VirtualBox host only adapter on Arch Linux.

The output of ip addr is:

5: vboxnet0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 0a:00:27:00:00:00 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::800:27ff:fe00:0/64 scope link 
       valid_lft forever preferred_lft forever

My VBox settings:

adapter setting

Guest OSs can comunicate between each other using host only adapter with ip addresses received from Virtual Box DHCP server but the communication between guest OS and host OS does not work on either side.

  • Do you have more than one guest? – MariusMatutiae Nov 24 '15 at 22:05
5

A user posted a very similar problem on the Arch forums. He solved it by installing net-tools. A quote from his post:

Apparently Virtual Box uses ifconfig rather than ip for setting up the network, just installing net-tools solved the issue.

So, try that simple solution first.

0

Here is a website that has commands to assign your machine to a IP address. Look through some of the commands on this website and maybe it will help you in your case.

http://www.tecmint.com/ifconfig-command-examples/

0

I do not know why your vboxnet0 network has not been assigned an IP address: on my system, given the same connection details on the Adapter settings mask, vboxnet0 appears with its proper address.

However, there is nothing wrong in assigning one manually: issue

 sudo ip addr add 192.168.56.1/24 dev vboxnet0

and now you may check whether the host-to-guest connectivity thru this interface has been restored; to do so, remember to bring down on the guests, at least temporarily, all other interfaces so that you are sure you are using vboxnet0 instead of any other interface.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.