3

In Keychain Access I would like to add Xcode to my the list of applications allowed to access a password.

I opened KeyChain Access on category Passwords, double-clicked the password I want to have the Access Control changed, switched to that tab and added Xcode in the list.

When I hit Save Changes, a modal window appears stating

Keychain access wants to change access permissions of the "the.key.com" item in your keychain

I have to enter my Keychain password, then hit one of three buttons: allow, deny or allways allow.

When clicking allow or allways allow nothing happens. The only option to dismiss the modal window is to click deny.

Same behaviour when I open a project using the password in Xcode. I get the same dialog with the same issue.

I did try the usual tricks like restarting, changing password, fixing permissions with DiskUtil and also searched a little bit, but the only thing I found does not fit to my issue as Xcode is not running.


Update: The complete login Keychain is affected, I can not make changes to any password

2
  • Were you able to resolve this? – Apophenia Overload Dec 14 '15 at 23:25
  • See my own answer below – dogsgod Dec 15 '15 at 5:30
2

Are you using VPN or any sort of software that's simulating mouse movements? See here:

"code sign wants to sign using key - Doesn't allow or always allow but deny works" https://forums.developer.apple.com/thread/25092

1
  • Thanks, this worked for me! I use a utility called MagicPrefs that changes my mouse behavior. Once I quit it and restarted XCode, I was able to allow access to the key. – Evan Feb 2 '16 at 1:25
1

Sorry if you have gone through some of these steps.

  1. Attempt to repair the keychain.
  2. If you're willing create and new keychain
  3. Delete the keychain preferences folder in the Library and see if that helps.
1
  • Yep, tried it all – dogsgod Nov 25 '15 at 14:21
0

The issue was introduced by OSX Server and the user _xcsbuildd and the related user folder setup that can not be handled by Keychain. File access rights are so messed up that I will reinstall OSX.


Edit: Reinstall probably was unnessecary. Although some access rights can no longer be altered in Keychain Access, there are fields for these in Xcode preferences and in some hidden options in OSX Server.

3
  • Hi @dogsgod I am having the same problem with the modal window, do you have an idea how I can fix this without re-installing the OS? – doorman Jan 17 '16 at 21:12
  • Use the IDE Apple decided to be responsible for this specific key. In my case it has been Xcode - changing account data in Xcode works fine, Keychain still refuses to update the key. I also had to learn, that editing over a VNC connection might not work (see other answer here), but it does work with direct access to the machine ... – dogsgod Jan 18 '16 at 8:05
  • brilliant thanks alot, this was it! I was using my mac remotely, when I tried it locally it finally worked :) – doorman Jan 18 '16 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.