1

A year or so ago I partitioned my stock 2011 MacBook Air with a 30Gb (I think) partition for Ubuntu. For a while I dual booted, all was good until eventually I purchased a dedicated Ubuntu machine and decided to return that space to my Mac.

I can't.

I killed the Ubuntu partition with Gparted, but couldn't find a way to extend the Mac partition.

Using Disk Utility I get the following problem

enter image description here

I've tried the suggested answers here: https://apple.stackexchange.com/questions/139157/restore-macintosh-hd-to-its-original-partition-configuration

But if I run diskutil cs list I get told I have no Core Storage volumes.

Any ideas folks?

Edit: I really don't care if I have to do a full machine restore. However, I have no time machine backup.

  • sounds like a corrupted partition table - best thing to do would be to backup the machine (if you are still able to boot into the main Mac OS), and do a full system restore using Internet Recovery (CMD + Option + R). This will reinstall the OS your machine came with and should re-adjust the volume. Once re-installed, transfer data back – Mike Diglio Nov 25 '15 at 19:05
  • diskutil cs list will find no core storage because you have no core storage, just a standard volume. diskutil list will show you your volumes. Try Booting to Internet Recovery Cmd/Opt/R & run Disk Repair from there. Then, whilst you're not booted from the drive you're trying to modify, you ought to be able to resize [you might need to kill the unlabelled d0s3 first. ] – Tetsujin Nov 25 '15 at 19:50
  • @Tetsujin - I can't seem to kill d0s3 from within Internet Recovery, and I get the a different error about file systems, but the same result when I try to extend the main partition. – JonRed Nov 25 '15 at 19:57
  • @Mike - When I tried to re-install it gave me the option of installing to the reduced size disk. I didn't proceed as wasn't sure there was a point... – JonRed Nov 25 '15 at 19:58
  • @JohnRed what happens if you boot into Single User (cmd + s) at startup and run disk repair. You receive any warnings or repairs? – Mike Diglio Nov 25 '15 at 20:53
0

your fatal error was to modify the partition with Gparted. Shoulda done that with DIsk Utility (click on that partition, and click the "-" at bottom of screen, then modified the Mac partition)....

considering the partition size and HDD size, I'd VERY MUCH recommend investing in a USB drive or thunderbolt drive, doing a timemachine backup, then partition the drive again and then reinstalling the OS and doing a recovery from timemachine to it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.