I used to have debian on my laptop. Then I removed the old hard drive (with the debian OS on it), and put it in a USB external hard drive box. And installed a new SSD hard drive into the laptop, installed windows 10 on it.

Now I am trying to boot into the debian system on my USB external hard drive when I connect it to my laptop and set the USB external hard drive as the top priority boot device in BIOS. The BIOS however cannot seem to detect the debian system on the external hard drive.

Is there way for this to work? Do you need more information to help me? Thanks!

  • Does it work if you just connect the USB external hard drive, without the SSD installed? – Hewbot Nov 25 '15 at 20:03
  • Try hitting F12 after post, before boot. Most laptops recognize this as a command to select the boot device, and will display a list of disks/devices to choose from. try selecting your (newly external) device and try to boot off it that way. – Frank Thomas Nov 25 '15 at 20:15
  • Thanks for the above comments! I tried to connect the UBC external hard drive before I installed the new SSD drive (so no internal hard drive at that time), but the laptop did not recognize the debian on the external hard drive. I also tried F12 (actually another key on my laptop) to select a boot device just before boot, still no luck ... – frankg1401 Nov 25 '15 at 21:04
  • Also just to add that the laptop can recognize the data partitions of the external hard drive, so there is no problem with the electric supply, connection, etc. – frankg1401 Nov 25 '15 at 21:10
  • Does the external drive show up on you BIOS boot device list? Some external drives aren't bootable. My old WD Passport is one example. If the drive doesn't show up on your BIOS boot device list, it's not bootable. Another thing I'd like to ask is have you installed GRUB, or some other boot loader, onto the external drive? – Larssend Nov 26 '15 at 0:46

It is really hard to know what exactly the problem is because we don't really see any error messages. Although, if there is an option in your BIOS called QuickBoot you should probably turn that on.

Something else I would do is plug the hard drive into a computer. And try to boot it from a virtual machine to see if the drive is corrupt. Look at tutorials for VirtualBox too do this.

  • Thanks for the advice. I will need to do this later because sounds like it will take some time. I will report back after I try. – frankg1401 Nov 26 '15 at 3:17

Are you sure that the OS on the HDD is bootable? You could try using a tool such as UNetbootin to install Linux, in this case Debian, to the drive via USB, preferably after taking a backup.

  • As a last resort you could reinstall Debian via USB, however I think frankg1401's objective is to continue using his existing Debian installation without reinstalling it. – karel Nov 26 '15 at 0:01
  • @karel True, what about if the original installation was kept but new boot info was written? It sounds like the HDD isn't being recognised as being bootable – James Vickery Nov 26 '15 at 0:03
  • Thanks for all the advice. Indeed I am trying to preserve the original Debian installation. I can actually see the USB hard drive in the bootable device list, but then I got the message "no bootable device -- insert boot disk and press any key". The original debian system was installed with GRUB2. The only change I made was to remove the original hard drive from the laptop and put it into a hard drive cassette. – frankg1401 Nov 26 '15 at 3:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.