I have Realtek RTL8187SE version 6.9071.822.2008 on Windows 8.1 and I'm trying to start a network but when I try to start the network it gives me "The hosted network could not be started". I set the mode to allow before I tried it. I went to enable ICS I installed the program Connectify to see if that would work but it tells me that my card isn't supported. I updated my driver from the website but I got a Code 31 so I uninstalled it and went back to the older version. I had the same driver when I was on Windows Vista/7 and it worked then. How do I fix this?

  • Did you try the command from an elevated command prompt? Right click on cmd.exe -> open as Administrator -> run the command – Smeerpijp Nov 27 '15 at 13:18
  • @doenoe Yes I tried it that way but it didn't work. – kprovost7314 Nov 28 '15 at 22:06
  1. In Device Manager :View -> Show Hidden Devices
  2. In Network adapters enable "Microsoft Hosted Network Virtual Adapter"

Microsoft Hosted Network Adapter

  • That driver is missing. – kprovost7314 Dec 26 '15 at 6:23
  • Does "netsh wlan show drivers" say "hosted network supported : yes" ? – krossner Dec 28 '15 at 9:44
  • I remember it saying no but I remember being able to start networks on Vista/7 with the same driver (but it may have been a different version). – kprovost7314 Dec 30 '15 at 1:07
  1. Try to uninstall your physical WiFi adapter
  2. In device manager, click on Actions - Find hardware changes - Wifi adapter should automatically appear again and so the Microsoft Hosted Network Adapter.
  3. If the Hosted Network Adapter is still greyed out, right click on your Physical Wifi adapter, Properties, Drivers, Revert driver changes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.