Windows 7 Ultimate 64 bit. Everything was working fine & then just stopped working.

The nic card Realtek PCIe GBE Family Controller is enabled but does not connect to my router (cables & router ports are good). Wireless Atheros AR5007EG is enabled but the connection is limited (encryption type / key have been verified). A laptop running XP can connect both wired / wireless. SSID is not being broadcast, connect to network if it is not broadcasting is checked.

Have checked services.msc for Bonjour & did not see it listed. Network & sharing center does not list any active networks. Device manager lists both devices as functioning properly. Router configuration has not been changed. Virus scan has not found anything.

I would like to fix this rather than using Acronis to do a system restore. Thanks in advance for any advice offered in solving this.

26 Jan, the nic card & wireless are working using PCLinux OS Live CD. It appears that the problem is Windows 7 related.

  • try reinstalling the wireless drivers, or update them or search for better ones
    – Lynob
    Sep 6, 2013 at 22:55
  • Also run sfc /scannow. Are you sure you didn't play with any essential networking services in services.msc Jan 13, 2014 at 22:19

3 Answers 3


Focus on your wired network first, as there's less software involved in it working. :)

Have you tried "safe mode with networking" yet? If you can connect by wire in safe mode with networking it wll help eliminate it as a hardware problem.

Have you tried using the Windows System Restore to go back to a date before it 'just stopped working'?

Have you ensured your anti-virus package isn't also a firewall that is blocking Internet traffic?

  • I have tried doing everything you suggested but it did not work. Starting to wish I did not turn off system restore. I tried turning off the anti-virus & it still did not work.
    – A302
    Jan 26, 2010 at 20:30
  • You may want to try temporarily uninstalling your AV package (not just diabling it), just to ensure it's not your problem. Can you ping while in Windows? Does it respond? Does the system get an IP address when in Windows? Does the system maintain a link LED (on the jack you plug your wired network cable into) after Windows is running? Jan 26, 2010 at 21:54
  • It was able to ping The link light was solid on the router. The router listed both the nic & wireless as connected to the router but they were not pulling an IP address. I ran the trouble shooter for both the nic & wireless and it said that windows could not bind an address to either. I checked & did not notice any changes to the router. Just to be sure I restored the router's configuration to what it was when I configured it. That did not resolve the issue. I booted the laptop using a restore disk for Acronis & the laptop was able to see & connect to my network drives.
    – A302
    Jan 28, 2010 at 15:46

In services.msc, make sure the WLAN AutoConfig service is enabled.

  • Thanks for the info John. I tried what you suggested & rebooted but it did not work.
    – A302
    Jan 26, 2010 at 4:27
  • What did you set the service to?
    – John T
    Jan 26, 2010 at 4:54
  • I set it to automatic.
    – A302
    Jan 26, 2010 at 20:26

Did IPv4 get unchecked by chance on the NIC? Have you checked the "connection" tab in internet options? Look for lan setting and set everything to auto/dhcp. I've seen a few machines loose their connections because jacked settings there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.