2

I have used windows 10 without problems for some weeks now on my office PC at work. I'm logging in with an active directory user.

I have recently upgraded to Windows 10.

Yesterday i encountered an error, that prohibited me from using any Windows 10 app, not even the calculator. With the permissions of our admins i reinstalled windows 10 today and thought it would work out. However, the starmenu is being quite frustrating since then.

If i log in with a local user on the machine, everything works fine. With my AD account, the startmenu is "broken".

View of start menu tiles (default)

As you can see, there are two entries without decent icons and no text. Clicking on of those opens up the Windows Store.

Further, i cannot find ANY installed program via the start menu search. If i type "paint", the search only offers to search the web. Entering "mspaint" offers running the command "mspaint", which of course will open up Paint as intended. However, other tools (like TeamViewer, Visual Studio, etc) cannot be found via the search, even if they appear in the "All Apps" list.

I have tried every solution from this thread, without any change.

The strangest thing is, that it seems to be account-bound. The local user or freshly created local users work perfectly, my AD user does not.

EDIT:

I found an article that explains the problems i have. Like i described, i used every solution there is for problems with apps. In Windows 1511, the "magic powershell command" to re-register apps, destroys the apps irrevertably...

  • Issues specific to corporate IT support and networks are off topic, see What topics can I ask about here?. Please talk to your IT department. – DavidPostill Nov 26 '15 at 15:08
  • In our company we are mostly responsible for our pcs, everyone has full admin rights on their machine etc. The IT department would not do anything apart from wiping my profile and creating a new one, which means i loose all my settings – Alexander Mills Nov 27 '15 at 7:17
  • Yes, but it appears to be AD related. IT need to be looking at why that is, as AD is out of your personal control. – DavidPostill Nov 27 '15 at 7:51
1

PowerShell command with the All Users option may work for Windows 10.

EDIT: Reorganized my post for added clarity.

WindowsApps folder permissions at %ProgramFiles%\WindowsApps may prevent you from successfully re-register existing Universal Apps. The first step is to grant yourself rights.

Command Prompt - Run as Administrator
Start > Run or Search > Command or CMD > Right-click and click Run as Admin.

PowerShell - Run as Administrator
Start > Run or Search > PowerShell > Right-click and click Run as Admin.

Using an Administrator Command Prompt

icacls "%ProgramFiles%\WindowsApps" /save "%TEMP%\WindowsApps.acl" /Q
takeown /F "%ProgramFiles%\WindowsApps"
icacls "%ProgramFiles%\WindowsApps" /grant "%username%":F /Q

Optionally you could add any other specific users other than the Current User.

icacls "%ProgramFiles%\WindowsApps" /grant "EXACTUSERNAME":F /Q

Finally, restore ownership rights to TrustedInstaller using this command.

icacls "%ProgramFiles%\WindowsApps" /setowner "NT Service\TrustedInstaller"

Next, temporarily Unrestrict the PowerShell environment to run it.

Using an Administrator PowerShell Prompt

Set-ExecutionPolicy Unrestricted (use before if necessary)
Set-ExecutionPolicy RemoteSigned (use afterwards if you run Unrestricted)

Fix All Universal Apps and use the All Users option.

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

The command above attempts to re-register all Universal Apps. You could also re-register Universal Apps individually as outlined below.

Fix Calculator App (see version path in %ProgramFiles%\WindowsApps)

Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_COPYYOURSPECIFICVERSIONPATHHERE\appxmanifest.xml"

Fix Windows Store App (see version path in %ProgramFiles%\WindowsApps)

Add-AppxPackage -DisableDevelopmentMode -Register $env:ProgramFiles\WindowsApps\Microsoft.WindowsStore_COPYYOURSPECIFICVERSIONPATHHERE\AppxManifest.xml

Final tip:
If there is a working clean-install v1511 instance or a successfully upgraded v1511 instance you can also copy the contents of C:\Program Files\WindowsApps from the good instance to the bad one. Do not overwrite, simply allow any missing components to copy without replacing any existing components.

The steps above have worked for me on several Windows 10 instances that we experienced problems on post in-place upgrading to version 1511 build 10586.

Regardless, I do not blame anyone who wants to wait for an official fix from Microsoft.

  • Sadly, i am on a post-1511 Version of Windows 10. I recently found an article describing that the powershell command will rather destroy the apps than fix anything. I'm waiting for a fix some day... – Alexander Mills Dec 10 '15 at 10:18
  • The command fixed my issues on my post-1511 build. From my outline above, the key for me was to first add permissions to my user account for C:\Program Files\WindowsApps and then use the 'All Users' option of the PowerShell command to re-register. Final tip, if anyone you know has a successful upgrade you can also copy the contents of their C:\Program Files\WindowsApps to yours. Do not overwrite the files just allow anything missing to fill in if yours had problems. Regardless, I don't blame you if you want to wait. I was impatient as even the new Calculator was broken. Steps above fixed it. – Ken Dec 12 '15 at 13:31
  • I tried, but no change. I keep getting "Cannot register the *** because there was a merge failure with the following file: C:\Program Files\WindowsApps***\resources.pri" errors when i try to run the command – Alexander Mills Dec 14 '15 at 8:13
  • Missing files in WindowsApps is the most common cause of 'merge failure' errors. > I witnessed it on a Windows 10 instance where WindowsApps did not contain both the to-be-updated-App and App-patches. > To fix it, I searched and copied all the verions back to the WindowsApps or copied the files from another machine. > In short, the migration tool broke it. In-place upgrade. Use option to keep your files and applications is the easiest solution for you. Details here link – Ken Dec 15 '15 at 15:10
  • The Windows repair actually worked!! Thank you :-) – Alexander Mills Dec 16 '15 at 8:54
1

None of the above solved my broken Modern Apps issue.

I had to perform the following:

  • Take ownership of the C:\Program Files\WindowsApps folder (as written by Ken)
  • Delete entire contents of C:\Program Files\WindowsApps folder
  • Perform in-place Upgrade/Repair Install

Things I tried that failed:

  • Ken's entire repair process
  • Upgrading to Slow Ring Builds
  • Upgrading to Fast Ring Builds
  • In-place Upgrade/Repair Install with broken apps still in C:\Program Files\WindowsApps

I'm not sure why my issue didn't resolve itself with the solutions above, but I hope that my solution may help others that also have difficulty with this issue.

0

I fixed the issues with help of the domain admins. The profile was completly wiped and reset to zero. After log in, Windows created a fresh user profile and the start menu search now works again and 60% of preinstalled apps (better than before)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.