3

I recently installed Windows 10 (upgrade from 7). It is an English version Windows, which I configured to the German locale(*), which uses a comma (",") instead of a dot (".") as the decimal separator, i.e. the number Pi is 3,14 not 3.14.

This works fine in Excel. However, it does NOT in the standard Windows calculator, which simply IGNORES a comma key press COMPLETELY. If I use a dot, it produces a dot which works as a decimal separator (which is wrong).

Note that I'm talking about the actual comma key here, not the numpad comma, which works fine but produces a dot in the Calculator (it produces a comma in Excel!).

My question: Does anyone have any ideas how to get Calculator to respect the German locale and recognize the comma key and display a comma?

(*) Control Panel > Change date, time, or number formats > Format: German (Germany). Under additional settings, the decimal separator is correctly set to ",".

  • 1
    It sounds like the calculator does not have that functionality. – Ramhound Nov 26 '15 at 16:14
3

To answer my own question: This is a bug in the Windows 10 calculator.

The problem did not exist in Windows 7, and it was NOT fixed in the first big update for Windows 10. As of December 2015, the bug is still there.

As usual there is no official acknowledgement. However, for a discussion on the Microsoft servers, see e.g. https://answers.microsoft.com/en-us/windows/forum/windows_7-winapps/windows-calculator-decimal-separator-is-always/d6e80dc7-9738-4a61-8457-c5e5d28beeb8?db=5&auth=1

0

Settings > Time and language > region & language > set as default for English keyboard and restart the windows

  • Have you tried this yourself? Does this work. Doesn't work for me – Prasanna Mar 2 '16 at 18:09
0

As you said yourself, this is a problem with the calculator in Windows 10 that hasn't been fixed yet. What I did to solve this for me was to install the Windows 7/8 calculator.

0

Control Panel > Region > Additional settings...

Change decimal symbol to comma and it will work as expected. Tried it myself just now and it works like a charm.

  • You might want to keep in mind the date this question was asked. – Daniel B Dec 19 '16 at 12:14

protected by Community Aug 2 '17 at 10:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.