2

I have some WInPE based media.. I think they're WinPE based..

One is a WinPE based Macrium Reflect bootable USB. (The linux based one boots fine). Another is WinPE 32bit. Clonezilla which is linux based, boots fine.

I've fiddled with some options in the BIOS e.g. boot mode has UEFI or legacy. And SATA controller mode had AHCI or compatible. But it doesn't make any difference.

It's an IBM Lenovo B50 30 Model 80 ES

enter image description here

enter image description here

It starts loading from the USB or CD

enter image description here

The BSOD

enter image description here

Note- this is not the same as this question "Bios Not fully ACPI compatible" That one is memory related. This one was fone with the old hard drive and i'vej ust put a a new blank hard drive in, which is equivalent to no hard drive. I'm booting from media e.g. CD or USB.

1 Answer 1

0

The answer may be that Win PE's older versions don't support UEFI or secure boot.. or perhaps, don't even support BIOSs that have those features(Since I think I even tried setting any features I could see off or to legacy, I couldn't get it to boot, though maybe the BIOS on that laptop is lacking in features to disable things like that).

Win PE version 10 is fine.

I managed to get a Win PE based Macrium Reflect USB to boot without that BSOD. I downloaded the latest Macrium Reflect, and it had an interesting screen for creating the rescue disk.. which is different to previous versions.

enter image description here

Note the last paragraph

"This wizard will create Windows PE 10.0 rescue media. Supports UEFI/Secure boot. , USB 3.0, HyperV Gen 2 VMs, and windows overlay filesystems. It's the best choice for Windows 10 systems. It is required for Win 8.1 WIMBoot and Win 10 compact installs"

So must be earlier Win PE versions have issues with UEFI/Secure boot. It seemed I couldn't change settings in the BIOS enough to get past that BSOD I was getting. But booting Win PE 10 USB worked (or linux). But not the older Win PE based USB that I was using.

Ramhound pointed out to me something along the lines of, that WinPE is the environment in which Windows installations boot from. (traditionally that was their use but later they became used also as a tool by techies in place of dos boot disks). So, that explains why early macriums and windows 7, give the BSOD in legacy, in that even with win7, it's the winPE part of it that is BSODing.

Perhaps it may be possible to install Win7 but from a later WinPE that doesn't BSOD. Though the BSOD is still a bit of a mystery, it may be somewhat irrelevant since it's just from an old WinPE that doesn't need to be used, rather than from the windows installation itself.

2
  • Only WinPE versions that are standard on Windows 8 and above support secure boot. Windows Vista and Windows 7 based WinPE support UEFI mode but require secure boot to be disabled. Windows Vista and Windows 7 require the device to be USB 2 with USB Legacy Mode enable in most cases. Windows 8 and above do not have the same requirement. Those version that don't support USB 3 can have the driver added to the image, so those devices can be used.
    – Ramhound
    Dec 2, 2015 at 18:19
  • @Ramhound ok but worth noting that none of that addresses the symptom of that BSOD though
    – barlop
    Dec 3, 2015 at 1:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .