0

Today I've updated IntelliJ IDEA EAP and got the following warning when opened a project:

Project Data Sources
Model format version 2.2 is too old (2.3 or more required)

Though the project seems to be working fine. I have never seen this message before and I am concerned about this.

What does it mean? Is there a way to fix it?

1

Go to your project's DB settings and choose 'update driver' in the bottom of pop-up. At least that's how I resolved the issue.

| improve this answer | |
  • You mean Database -> Data Source Properties ? I can't find 'update driver' option there. But dropping and creating connection again solved the problem. – naXa Nov 27 '15 at 11:55
  • Yep, that exactly what I meant – user1795707 Nov 30 '15 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.