6

I am using Google Chrome 46.0.2490.86 (64-bit) on a Mac.

When I go to a URL with a PDF file, it displays correctly. But if I try to save it, Chrome fetches the URL a second time from the remote website, then saves it to the named location, then opens the PDF with a file:/// URL.

This is NOT what Safari does (and I don't think that it's what Chrome used to do). I want it to save to the drive the PDF file that it's already loaded, and then... just leave it, please.

Is there any way to make Chrome behave in this manner?

  • Why does it matter? :P – Insane Nov 28 '15 at 5:04
  • 1. Sometimes I hope a PDF file in a tab and want to save the file when I don't have Internet access. Safari would let me save it, but Chrome doesn't. 2. Sometimes a file is HUGE and I don't want to download it again. 3. Sometimes files are removed from servers and my only copy is the version in the tab. 4. Sometimes I want to save the file but not open it in another tab. – vy32 Nov 28 '15 at 21:16
  • So basically, Chrome tries to fetch the current PDF where Safari saves the local version from your cache saved on your computer. Honestly, you're not going to find a fix for this on Chrome. I'd suggest improving your browsing habits as to not having PDF tabs open if you know the content might go down or if you might lose internet access. Download the files right away and then this will be a non-issue. – Insane Nov 28 '15 at 21:19
  • My question is: "s there any way to make Chrome behave in this manner?" – vy32 Nov 29 '15 at 0:43
  • 1
    Well, I figured that an extension might be one way to answer the question, which is why I asked it! – vy32 Nov 29 '15 at 1:41
5

To save the file without fetching from remote server again, do Print-> Save as PDF.

  • I've tried following your steps. This produces two different files from this pdf: $ diff adobe_supplement_iso32000_save.pdf Acrobat\ Supplement\ to\ the\ ISO\ 32000_print.pdf Binary files adobe_supplement_iso32000_save.pdf and Acrobat Supplement to the ISO 32000_print.pdf differ – sashk Dec 1 '16 at 13:49
0

Possible related issue to double-download has been fixed recently.

As to disabling automatic opening of the PDF after saving, there are two methods:

  1. Open, then save any pdf file in Chrome (you can use this sample pdf). After you save it, click the arrow in the download bar, and uncheck "Always Open With Sytem Viewer" setting.

    disable auto open of pdf

  2. Go to Chrome Settings, scroll to the bottom and click Advanced settings. Scroll down to the Downloads section and look for "You have chosen to open certain file types automatically after downloading." Click button "Clear auto-opening settings" button and your PDFs won't auto open.

    Downside of the second method -- it will clear auto-open setting for all file types, not just PDFs.

    Source.

0

Move your mouse on the screen and a menu should appear on top of the page. You should see an image of a printer on the right side of it. click on that and then under Destination click on change and choose save as PDF from the menu.

It will work even if you don't have an internet connection.

0

I think op needs this answer:

This behavior can be switched off, only the setting is a bit hidden:

  1. Go to chrome://settings/content
  2. Scroll down to "PDF Documents"
  3. Uncheck "Open PDF files in the default PDF viewer application"

Taken from: https://superuser.com/a/1177756

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.