4

I am trying to disable the Windows 10 driver signature verifier.

This is causing constant BSOD errors - all showing "Driver Verifier IOManger Violation"

I am trying to install an old video driver. I would like to completely disable the verifier program, but so far I can't.

I have spent the last few days researching and trying every variation of the following strategies


I rebooted into advanced setup options

in cmd.exe

shutdown.exe /r /o

I then hit F7 to disable driver signature verification


I opened gpedit.msc

Enabled the option for code signed drivers

Enabled Test Mode


I tried to disable any video drivers in use under device manager, but there are no video drivers installed at all.


In cmd.exe I ran "verifier" to open the driver verifier manager

I choose "Display existing settings"

All options read as "no"


I set compatibility mode on my driver install package and am running as administrator


After every install attempt the BSOD screen appears with the driver verifier error message.

Suggestions?

  • Have you tried "Delete existing settings" in the Driver Verifier Manager? Another option would be to boot into Windows Recovery, select Command Prompt, and run verifier /bootmode resetonbootfail. Reboot the PC after doing so. – Gavin Nov 28 '15 at 7:06
  • have you looked in the registry for the values and deleted them? – magicandre1981 Dec 5 '15 at 8:44
  • "Driver verifier" , the thing you get to by typing "verifier" from the command prompt, has absolutely nothing to do with driver signature verification. – Jamie Hanrahan Jan 28 '17 at 14:56
5

the verifier settings are stored in the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\VerifyDrivers and HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\VerifyDriverLevel. Delete both entries to get rid of Driver Verifier.

1

I'm going to leave this here for anyone who has the same problem I did:

  1. Click on "See advanced repair options"
  2. Go to "Troubleshoot"
  3. Tap on "Advanced Options"
  4. Click on "Start-up Settings"
  5. Press 4 to start up in safe mode
  6. Once you're logged in, type run
  7. Type verifier.exe
  8. Click "delete existing settings"
  9. Go to the start menu and click "restart"

Hope this helps. I was in a frustrating loop where NOTHING was disabling driver verifier, but this worked for me, so I hope it does for you too.

protected by Twisty Impersonator Jan 5 at 12:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.