0

I have a long distance WiFi point-to-point connection. It works well most of the time, but then occasionally acts up. When it does act up, I have problems connecting vie NetBIOS (Utilizing both alphanumeric and TCPIP UNCs) over that network segment to files on another Windows 7 PC. That is fine, except that NetBIOS seems determined to make the connection. As a result, I must wait more than a minute for it to try whatever it is trying before timing out and throwing a "I can't connect" message.

My question then is, how, or what, do I change to keep Windows from going on a long walk trying to make a connection, and just give it the "ol' college try" and then give up quickly. I would like to change wait times from over a minute to seconds if possible.

Review: WiFi connection issue is not part of the question. NetBIOS connection works well normally, but takes an inordinate amount of time to timeout if network is problematic. How do I get Windows to timeout sooner when trying to make an ill-fated NetBIOS connection.

Thanks in advance.

4
  • Appendix B: NetBIOS over TCP/IP Configuration Parameters lists a number of different timeout values used by NetBIOS. I'm not sure if any of them are responsible for your issue as they are not set (by default) to around 1 minute. You could take a look at these registry values on your system and see if anything stands out.
    – DavidPostill
    Nov 28 '15 at 9:58
  • In addition, Win2000 and newer machines uses the DNS (hostname) process FIRST before the NetBIOS resolution process. If it does not get resolved using the DNS process, then it uses the NetBIOS process. The default DNS timeout value is 10s, so again that doesn't fit your issue.
    – DavidPostill
    Nov 28 '15 at 9:59
  • David, Thanks. I remembered Wireshark and installed it. I do see a bunch of ARP requests until the attempt finally times out. I will try some of those Reg. changes highlighted in that document in the morning. Note: Only after posting this question did I remember that there is such a tool as Wireshark.
    – JayJay123
    Nov 28 '15 at 10:51
  • arp is a good catch. I don't think any of those reg values are related to arp though. Please let us know what you find out.
    – DavidPostill
    Nov 28 '15 at 10:57
1

As per DavidPostill's info, it seems that my multihomed PC, which has several VMWare "adapters" as well, is sending ARP/NetBIOS requests to all of these adapters. Changing the BcastNameQueryCount count number to 1 has improved things--still not great, but better.

So that is the answer. I will then just have to live with the not so good, but improved situation.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.