2

My laptop can't connect to internet. My 2 network interfaces (Ethernet and WiFi) seem to be problem. If you can see in the screenshoot, it shows blank properties if I click Details button.

Network properties through GUI

And here's screenshot if I click Properties button, it seems to be normal

Network properties - config

But if I take a look at command line (ipconfig /all), it seems that 2 network interfaces are not listed there, only Cellular connection is available.

Network properties through command line

All I know that this problem happened after uninstalling iTunes. FYI, I use Windows 10 Pro x64. What I've tried:

  1. Disable and re-enable network interface
  2. Uninstall driver
  3. Set all connection properties manually (IP, netmask, default gateway, DNS server, etc). But default gateway is always reset to blank.

I used this troubleshoot reference. Method 1, I found no Config key in this registry key. Method 3: no problem with this key, it's contained same contents as mentioned in this article.

Any help will be appreciated

Update 1

Add screenshot for Ethernet Status - Properties

Update 2

Just try to use USB WiFi which is confirmed to work in another computer, doesn't work on my laptop.

0
2

ipconfig is not showing your eth0/wifi nterfaces, just cell & virtual adapters used with it.

if you look in eth0 properties do you have the typical clients/protocols attached? eg, microsoft client, link layer topo, discovery adapter & ip4/6 protocols?

I suspect since you uninstalled the driver it has lost some or all of those items. You should be able to add them back through the install button if they are missing. You'll need at least one protocol (ip4 is usual on most private networks) & the microsoft client.

2
  • I've updated the question. I hope this is what we're looking for. It seems to be normal having all protocols. – iroel Nov 29 '15 at 2:22
  • Thank you for answering. However, your answer triggered me to dig about installed protocol. Although I couldn't find it through GUI, but this clue drove me the solution. I really appreciate it. – iroel Nov 30 '15 at 16:44
0

After investigating and digging to find the solution, I find official reference from Microsoft. From the last solution, by executing netcfg -v -s n to show all installed network services, I see there's JumpStart service which's been uninstalled before. Yes, I used JumpStart WiFi previously and uninstalled it. So what I've done it just install and uninstall JumpStart WiFi for the second time. It seems I didn't uninstall it properly, making my network interfaces work incorrectly. And rechecking netcfg -v -s n again and no JumpStart service found anymore. Now, both my WiFi and LAN interfaces work correctly.

0

This worked for me:

https://support.microsoft.com/en-gb/help/10741/windows-10-fix-network-connection-issues

Specifically this part: (type it in the console as admin)

netsh winsock reset and press Enter.  
netsh int ip reset and press Enter.  
ipconfig /release and press Enter.  
ipconfig /renew and press Enter.  
ipconfig /flushdns and press Enter.  
0

It happens sometimes with Symantec EndPoint (11.x and up) installation.

just uninstall it to get your network config back then reinstall it again

2
  • 1
    How does Symantec EndPoint relate to this question? – Stephen Rauch Jun 16 '17 at 16:15
  • Unfortunately, I don't have symantec installed – iroel Aug 4 '17 at 1:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.