1

On my son's Windows 10 Pro laptop, an HP Probook 4540s that was upgraded from a previous Windows version, it will not shutdown...

The laptop starts the shutdown process with the spinning windows thingy, then the screen goes black but the power light stays on and the hard drive light flickers occasionally except it never powers down, then after about 1.5-2 minutes the desktop just pops back up (not like the computer was restarted, just pops back up) but it didn't reboot.

The strange part is selecting Restart has very normal behavior, the Windows Restart screen with the spinning windows thingy pops up for about 15-20 seconds, then it shuts down and the BIOS screen pops up and it reboots normally.

So on a restart the laptop is doing the shutdown process normally and restarting, but on an actual shutdown it is not getting to that point (no BIOS screen) and the desktop just reappears after a couple minutes.

I have tried updating and downgrading the Intel Management Engine Interface like several online help forums mentioned, but it didn't change anything.

My son is getting very frustrated since he has to hold the power button to get it to shutdown, which he knows can cause issues.

Any ideas on how to fix this?

  • Have you seen Windows 10 doesn't shut down properly and looked at all the answers? To get a safer shutdown in the meantime, your son can try holding the power button immediately when the BIOS screen appears after the reboot, hopefully that will power-off the laptop before Windows has a chance to start. – Andrew Morton Nov 28 '15 at 15:29
  • I already went through that link, none of those solutions were effective. – acejavelin Nov 28 '15 at 15:42
  • 1
    The shift key gives u options such as the ability to set boot flags (if u have an ssd and want to get in the bios/uefi and cant press the buton fast enough) or windows recovery etc... – user584410 Apr 18 '16 at 16:01
2

The fix is shown here: https://www.youtube.com/watch?v=bDWtGC5VbEM

The jist of it is disabling "Fast Startup" in the shutdown options of the Power Options menu. I could not get "Power Options" to appears in the menu or by search, so here is how I did it.

I went to Start -> Settings -> System then select Power & Sleep and scroll to the bottom and pick Additional Power settings, this opens the Power Options menu. Now select "Choose what the power buttons do" and then "Change settings that are currently unavailable". Scroll to the bottom and under Shutdown Settings untick "Turn on fast startup (recommended)" then Save Changes and it works now. Three attempts and all shutdowns completed normally since making the change.

  • Not a good solution but works – Suici Doga Apr 6 '16 at 3:39
  • 1
    @SuiciDoga No offense, but how is this not a good solution? The hardware/UEFI/BIOS implementation by the manufacturer is such that a specific level of power management (meaning Fast Startup or Deep Sleep) doesn't work, but Windows can't doesn't know that, so we have to manually let Windows know it doesn't work. It is a simple, elegant solution... One tick box. – acejavelin Apr 6 '16 at 3:46
  • It was working before I dual-booted Linux using GRUB2 and rEFInd and replaced bootmgrfw.EFI with refind – Suici Doga Apr 6 '16 at 4:24
  • 1
    @SuiciDoga Google "Windows 10 fast startup with dual boot linux" and read some of the links (I'm to tired to do it now), you will see why this is very common... Even Ubuntu recommends it in multi-boot installations most of the time. Fast Startup is more correctly called Hybrid Shutdown, essentially the device isn't going completely off, making grub2 not work correctly. – acejavelin Apr 6 '16 at 4:33
  • @SuiciDoga This article explains how/what "Fast Startup" really is, it should clear up the confusion of why it needs to be disabled in some cases. howtogeek.com/243901/… – acejavelin Apr 6 '16 at 4:38
0

The issue really is how the boot partition is configured. Anyways in order to repair my HP ProBook boot partition I used a Windows 10 recovery USB/CD. Proceeded to do a custom install and in the partition selection menu delete partition 1(1GB size) which is the boot partition and partition 3 (100mb size). After deletion just hit the x at the top to cancel setup.

Now if you try to start your PC it won't boot to Windows cause you just deleted the boot partition. Don't worry, using the Windows 10 recovery USB used earlier follow method #2 in this tutorial to restore the deleted boot partition. https://www.partition-tool.com/resource/partition-recovery/restore-repair-deleted-efi-boot-partition-in-windows-10-8-7.html Now boot as usual to Windows 10 and re-enable the fast startup option and see for yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.