13

I upgraded my Mac OS To OS X El Capitan.
Now it is not getting connected to internet via Ethernet cable but Wireless works just fine. What happens is when I connect the Ethernet cable it says self assigned IP as shown in screenshot.

![Self assigned IP MAC Ethernet

I have tried to manually enter all IPv4 information but doesn't help

1
  • Simply rebooting my computer worked for me. Sep 14, 2017 at 17:20

3 Answers 3

5

This article will talks about the Self-Assigned IP issue and will hopefully fix your problem. Here is the relevant part:

To reset the firewall, go to the /Macintosh HD/Library/Preferences/ folder and remove the file called "com.apple.alf.plist," and then restart your computer. After the system boots, you may be prompted to allow incoming connections to numerous programs and services, so accept these for now (you can always go to the Firewall settings and deny or remove entries later on) and then try connecting to the network again. While configuration changes from migrating or restoring a system can lead to this problem, at other times major system crashes or power outages can do the same.

3

I was having the same issue and couldn't resolve until I followed this advice:

Many cable modems bridge only the first MAC address they see. If you unplug your router and plug in your Mac, you may need to reboot your cable modem so it accepts the Mac's MAC address. You'll need to reboot it again if you switch back to your router.

Source: MacRumors forums

In my situation, I had unplugged the ethernet cable from my wifi router and plugged it into my Mac. My cable modem presumably didn't bridge the new MAC address, leading to the network problem. Rebooting the cable modem resolved the issue.

0

It sounds like perhaps the wire and/or setup of DHCP (assignment of IPs) might be an issue.

Here are some items to try in order:

  • I would verify that the cable is making a good connection on both sides. Disconnect and reconnect both ends.
  • Try a different patch cord.
  • Check your network settings: System Preferences, Network, Click on the Ethernet on the left. On the right, it should say "IPv4: Using DHCP" on the drop down.
    • If that was already set, try the "Advanced" button, then "Renew DHCP Lease"
  • Finally, some people have reported success by removing their "Ethernet" config from the Network settings and then re-adding. To do this:
    • Click on the Ethernet entry on the left in Network Settings
    • Click on the minus sign under the list (this removes it)
    • Click on the plus sign under the list. Select "Ethernet" on the Interface Dropdown (this will add Ethernet back)
    • Finally, click APPLY for the new interface settings to be saved. After a few seconds, you should see "connected" and clicking on the interface will show you your IP address.

If these don't work, you might have a legitimate hardware issue. I would recommend a call to Apple (they will help you over the phone generally, depending on how old your Mac is and whether or not you have Apple Care.) Alternatives: a visit to your local Mac shop (there aren't many, but there are some) or a visit to your local Apple Store.

2
  • I have tried all the steps mentioned above, still no luck.
    – anonymous
    Nov 28, 2015 at 18:43
  • Would you do a screen grab of your Ethernet settings in Network Settings? That might show something interesting. Sorry the other steps did not help! Nov 29, 2015 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.