0

Setup:

  • 2 monitors [DVI]
  • 1 TV [HDMI]
  • Card: Ati Radeon 6850
  • OS: Windows 10

Situation:

When I plug the HDMI into the video card my monitors turn off. Switching one of them off does not make a difference. The moment I unplug the HDMI, the monitors wake up. Drivers are up to date.

What is the cause of this?

0

It could have something to do with hdcp (high definition content protection) which is mandatory for example if you play blue ray discs via hdmi (all hail DRM). It could be that your DVI monitors don't support hdcp and the graphics driver activates hdcp as soon as you plug in the TV. See if you can find an option to disable HDCP and try again.

  • I've had this setup working on Windows 8, so it's not that. – Mariyan Nov 29 '15 at 7:19
0

So here is what I did here to be able to switch between monitors and TV:

When the 3 cables are plugged in there is no way all the monitors will work.

Go to display settings and mirror TV and one of the monitors. The second monitor should be disconnected. That way the TV works. What I found out is that only one of the monitors can work with the TV, while the other one does not want to. Should be port conflict or something.

Again go to display settings and disable the TV and enable the second monitor. That way both monitors work.

I found a program called monitor profile switcher that remembers setting profiles so that I don't have go through settings every time.

P.S. Get latest drivers as well. And this is not windows 10 specific like I indicated initially.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.