24

I had VirtualBox installed on Windows 8.1 and it was working correctly. I upgraded to Windows 10 and re-installed VirtualBox, but it's very slow.

System Info:

  • CPU : Intel Core i5
  • Graphic Card : Nvidia 740m
  • 6 Gigabyte RAM
  • 256 GB SSD Storage

Drivers are up to date. 3D Acceleration is enabled.

What's the problem?

4
  • By slow do you mean graphics are very delayed? I experienced the same issue in VMWare Player as well. I have yet to find a solution. – Gavin Nov 29 '15 at 10:32
  • Yes, is the same. Please show your solution. – Ali Nov 29 '15 at 11:34
  • You are using the current version of Virtualbox I presume? – Ramhound Nov 29 '15 at 13:56
  • I use the latest version. – Ali Nov 29 '15 at 14:00

16 Answers 16

21

It seems you're on a laptop, so tweaking Windows power options may be a solution:

http://www.rawinfopages.com/tips/2015/05/speed-up-virtualbox-enormously-with-this-simple-tweak/

To quote:

So it turned out to be a simple problem, partly caused by selecting the wrong power plan. Make sure that the High power plan is selected when running virtual machines VirtualBox.

After some more experiments, I found that by raising the minimum processor speed when running on mains power raised the CPU speed. Setting it to 80% made the minimum speed 2GHz on mains power, which was fine for running the virtual machine.

To do this, go to Power Options in the Control Panel and next to the Power saver plan, click Change plan settings. On the next screen, click Change advanced power settings. Expand Processor power management, Minimum processor state, and set Plugged in to 80% or whatever value gives reasonable performance in the virtual machine.

10
  • 3
    power plan is High performance mode – Ali May 9 '16 at 11:27
  • 1
    This worked for me, alongside disabling the host I/O cache in the disk settings. – Polynomial Jun 28 '16 at 15:58
  • 2
    @Polynomial Sorry, you disabled the I/O cache? shouldn't that make it slower? – Kyle Strand Nov 14 '16 at 18:23
  • 1
    crazy enough, this totally fixes the problem. cray-cray <3 it. i also installed the virtualbox guest additions which you should always do anyway. not sure if that might have helped too. – Nicholas DiPiazza Oct 16 '17 at 20:07
  • 5
    Did you make the change on the host or guest? – Jeff Aug 12 '20 at 20:48
13

I had the same problem today -- found that the "Graphics Controller" (Display tab) had defaulted to VBoxSVGA. Clicking over all my VMs, it was the only one on that setting. So I changed it to VBoxVGA, and voila - no more lag! It was so bad, I'd see the display update in the VirtualBox Manager mini preview, so I'd click off the VM then click back and the display would update. Good as new now.

1
  • 3
    That did the trick (adding more memory / cpus didn't do shit). Huge difference in graphics lag after I switched to VBoxVGA. – PerrierCitror Jul 19 '19 at 13:48
9

I noticed a significant boost in Windows speed after enabling 3D acceleration from the Display settings panel.

6

1) You might exclude from antivirus & Windows Defender:

Search Virus and Protection > ... Settings > Add Exclusions > Add Folder -> C:\Program Files\Oracle\VirtualBox

enter image description here

2) Check the Execution cap. I use around 30-70%

CPU Execution cap limits the amount of time a host CPU spends to emulate a virtual CPU. The default setting is 100%, meaning that there is no limitation. A setting of 50% implies a single virtual CPU can use up to 50% of a single host CPU.

enter image description here

5

Make sure that you have the VirtualBox Guest Additions installed, which ensures that the virtualized OS can work better with the hardware exposed through the host.

1
  • 6
    I installed it, but nothing changed – Ali May 9 '16 at 16:46
5

More weird things with Windows 10 guest (after clean install), on two different hosts.

On one host with Windows 10 host, the VoxSVGA + 3D works acceptable.

On the other host with Linux Manajaro (last LTS kernel 5.x) host, the VBoxSVGA (with and without 3D accel) makes the guest to not reach desktop, freezes prior to dots moving, BSOD, etc.

On such other host with Linux Manajaro (last LTS kernel 5.x) host, the VMSVGA with 3D accel makes the guest to not reach desktop, freezes prior to dots moving, BSOD, etc.

On such other host with Linux Manajaro (last LTS kernel 5.x) host, the VMSVGA without 3D accel makes the guest to reach desktop, but so slow that it is unusable, more than half an hour to reach desktop, more than ten minutes to show windows menu after click, more than five minutes to show contextual desktop menu, near two hours to open explorer, near one hour and a half to open notepad, near 45 minutes to open cmd console window, typing the four characters of "CD \" took near two full minutes, listing shown was one character every four or five secons, etc. and near five hours to do a shutdown.

With a lot, lot of patience, i had tried to uninstall, reboot and re-install AddOns, that took a whole week, near 166 hours, but that did not help, still the same.

As i said Windows 10 is a clean install.

The weird thing is that such guest install was done on an Intel Windows 10 host and speed problems appear on an AMD Linux host.

If i install the guest on AMD Linux host it works acceptable, but if i take that guest to the Intel Windows host, then the guest has the exact same problems, BSOD or very slow, depending on (VBoxSVGA with/without 3D and VMSVGA with 3D = BSOD) vs (VMSVGA without 3D = very slow).

Very slow = A lot of minutes (>30 min) to just boot, some hours to do a clean power off, etc

BSOD = Not reach desktop, just freeze or BSOD and auto-reboot.

It happens only with Windows 10 guest, i had tried with and old WinXP guest i had and such worked perfectly on both hosts (i can move the WinXP guest form Intel to AMD back and forth without problems, but not the Win 10 guest).

I also had tested with default settings that VBox uses when creating the VM, with all sorts of combinations (PAE/NX, IO, cache, etc), the only thing that causes any difference on BSOD vs reach desktop is selecting VMSVGA without 3D, but hten that VM is too slow to be able to be used.

Both host have decent modern processor, 8GiB physical RAM (2GiB to guest).

And yes, i had tried with max guest video memory size, no help at all. Also 100%, 90% .. 50% of CPU did not help; guest with only 2 cores so host have plenty of cores extra (Intel is quad core no multi-threaded, AND has 32 cores with 64 threads).

This problems appear after VirtualBox change to 6.x from 5.x, but with 5.x no matter what video configuration i use the win 10 guest BSOD problem was allways appearing if i use the VM guest on AMD if installation was done in Intel and vice-versa, so at least with VBox 6.x i can reach desktop (with 5.x i can not) but it is unusable.

4

I disabled host I/O cache from Vbox settings and it worked oddly (yes I know this doesn't make sense but it worked anyway and I wanted to share).

4

In my case, it was because Hyper-V was enabled. I had it disabled in Windows Features but I was still getting the turtle icon in the bottom right of the VirtualBox guest window. To turn it off completely, I had to:

  1. On the host computer, open Command Line (as Administrator).
  2. Enter the following command: bcdedit /set hypervisorlaunchtype off
  3. Restart the host computer.

After this, there was no lag at all.

3

I currently had same issue with WIN8. GuestAdditions was installed, but WIN8 Image was really slow.

I solve it by remove GuestAdditions, restart the VM and reinstall GuestAdditions. Seems there was GuestAdditions 4.x all the time in the Win8 VM, but got no notice to update the GuestAdditions. Now I have GuestAdditions 5.2 and VM runs fast and smooth.

3

For me it was System>Chipset set to PIIX3. Once set to ICH9 everything got up to speed.

2

On Virtualbox adding extra processor in VM settings and giving more memory helped me.

2

In my case, it was the AVG Business edition anti-virus! it made my oracle VM unusually slow. If you are facing unusual slow performance I will suggest you to disable anti-virus completely and check if it improves. Later you can add the oracle vm's path in the exception list (in AVG, these were in File shield and Behaviour shield ).

Note: Even windows defender can make it slow. So in case you do not have any anti-virus, please check after disabling the windows defender first.

1

My windows 10 VM was very very slow and I tried many solutions like change the VM graphic card, it helped but still slow, simply change the hard drive from dynamic to fixed made my Windows 10 VM much faster.

1
  • Please expand your answer to include the information about how fixed the issue. – Xeнεi Ξэnвϵς Jan 28 at 8:28
1

My VM became very slow since the last Windows update. I tried many suggestions, but only "bcdedit /set hypervisorlaunchtype off" command helped me and made my Sierra fast again.

1

Turning on Use Host I/O Cache on the SATA controller gave me a very noticeable boost

0

I have been stuck with this issue for days, tried the suggestions from all the posts in this discussion. At the end, the one that worked for me was turning off hyper-v hypervisor.

Not the answer you're looking for? Browse other questions tagged or ask your own question.