7

I upgraded my old computer with a Samsung EVO 850. I did a clean Windows 10 installation.

Installed Samsung Magic and fixed all the AHCI settings. Now I have full 6Gb/s transfer speed.

However, my problem is Windows "Optimize Drives" tool wants to defrag my SSD like a hard drive. As far as I know, this is bad.

The rest of the OS works fine, and my 3rd party programs see that it's a SSD.

CPU: Intel Core i7 (4th gen)
Mobo: Asus P7P55DE_PRO
RAM: 8GB

1
  • 1
    I had the exact same problem, just the other way around.
    – aman207
    Jan 7 '16 at 3:15
8

Windows detects the type based on the benchmarks results. Run winsat formal from a cmd.exe, started as admin to bench the drive again.

Now Windows should detect the drive again as SSD and should only TRIM it and don't do a fully defrag.

3
  • Ok, it now shows my "solid state" media but optimiation isn't available for some reaons. Thank you so much for the help btw. Dec 1 '15 at 3:19
  • maybe this means "no action" needed for the drive. Accept the answer to "close" the question. Dec 1 '15 at 5:03
  • 3
    What worked for me was to run winsat disk -drive X for each of the drives, as winsat diskformal only seems to do the first drive and I have multiple partitions on the first disk, so it was still detected as HDD.
    – Natan
    Mar 30 '18 at 10:57
1

Command winsat formal didn't work for me, I used winsat diskformal

0

The culprit in my case was the Intel Rapid Storage app. The acceleration mode was on maximized. I switched off acceleration mode completely then reset acceleration mode to enhanced (a couple of restarts are involved in this process).

HDD now shows correctly and Windows auto defrag now functions.

0

Same issue here with a Samsung EVO 850 recognized as a HDD and shown as removable in the systray, across numerous versions of Windows 10 Home. Machine is an hp Omen 870-267nz which turned out to have only 3 SATA connectors on the motherboard, one of which was used for the DVD drive. I wanted to have a 2nd SSD and keep the HD, so connected the EVO 850 SSD instead of the DVD drive, which works just as well over a USB adapter connected to a free USB 2.0 port. Spent a lot of time trying the suggestions above and others to no avail. SSD didn't show up in BIOS but was detected in Windows as a hard disk - functional but defragmenting instead of trimming. Finally opened the case and swapped the SATA connectors of the SSD and HD this morning. Now SSD shows as SSD, no longer removable. HD still shows as HD, but has become removable. Time to reformat the EVO 850 to make sure alignment is ok and it will be all good :-) Bottom line: apparently the 3rd SATA connector on the motherboard has limitations that don't matter with a DVD drive but make it less compatible with SSDs and HDs.

-1

None of the above work for me, every time when I run any of the commands, it only runs the benchmark on my D: drive, which is a HDD. Even when I run winsat disk -drive C to indicate the SSD drive, it still starts benching D:, and in the end C: remains marked as HDD (it's a SanDisk SSD). If I run winsat disk -drive D: it runs the benchmark also on D: It doesn't matter what I tell it, it won't touch the C. Anyone has any ideas?

2
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context.
    – Ramhound
    Aug 28 at 2:49
  • Please provide additional details in your answer. As it's currently written, it's hard to understand your solution.
    – Community Bot
    Aug 28 at 5:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.