2

All is working fine with DEV C++. Suddenly it stops working. The Program is compiling with no error messages. But when I hit the run button, nothing happens. This is happening with all programs. So there is no issue with the specific program.

This was also happening earlier with me. Then I reinstalled DEV C++ and it worked fine. But after sometimes it started again. I don't want to reinstall it again and again. Currently I'm using Windows 10.

Any help will be great. Thank You.

  • Description for the dev: "The Linux/Unix /dev directory contains the special device files for all the devices. " (see superuser.com/tags/dev/info). This is not the tag you are looking for.... – Hennes Nov 29 '15 at 18:21
  • Are you writing console apps and compiling them as Win32 apps? An EXE compiled for the Win32 subsystem does not create a console window, so if you wrote a console app, you won't see anything. What happens when you try to run the program directly on disk? Don't hit the Run button; go to the folder where your project is stored and actually run the executable itself. See if it does anything. If not, you're probably compiling for the wrong subsystem. – allquixotic Nov 29 '15 at 19:40
  • Same program is running well in DEV C++ and on same system. Before it start not to run any program. – Hemant Parihar Nov 29 '15 at 19:59
2

Finally I solved. It was my avast who is blocking the application to launch. Avast is considering the application as a false positive means as a threat to the system(false).

Avast was wrong it was not a threat for the system. That's why it is a false positive. Then i add an exception(rule) to avast not to scan a particular file/folder. But this is also not working well.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.