I have a program for which I generate a .deb file. The .deb file works fine on the systems I have tried it on (also tested with lintian). Previously it has worked to use alien to convert this to .rpm and install it on Suse. However it is now about a year since I tried it the last time and now I get an error when trying to install the alien made rpm on Fedora 11, I get this error:

file /usr/share/icons/default.kde from install of testpkg-0.2-2.i386 conflicts with file from package kdelibs3-3.5.10-13.fc11.1.i586

Listing the content of the rpm file:

$ rpm -qlp testpkg-0.2-2.i386.rpm

Am I wrong in putting the kde icons in /usr/share/icons/default.kde which seem to be a symbolic link ? It's a symbolic link on both Kubuntu 9.10 and Fedora 11 though.

Sounds like a common situation that the same directory is needed for different packages, so why is it a conflict ?


You already have explained the problem with trampling over the path that belongs to a different package in detail yourself, I cannot add more than "so don't do it".

Read http://specs.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html#directory_layout, install the icons under /usr/share/icons/hicolor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.