6

In the last few weeks I've noticed my macbookpro (mid-2014, core i7, retina 16Gb RAM, el capitan patched to latest) running quite hot and looking at the CPU usage it seems it's cfprefsd that's doing the damage with over 90%.

I'm aware cfprefsd is just covering up for some other process but I don't know how to go about finding out. Anyone have any ideas?

4

It is possible that when we upgrade from Yosemite to El Capitan, our bluetooth settings are backed up and are read by the system.

I found that this was the file that had a few duplicates: /Library/Preferences/com.apple.Bluetooth.plist

sudo removing all these files then doing a PRAM and SMC reset immediately worked for me!

PRAM and SMC reset : Shut down your Mac, press the power button, and as soon as you hear the startup chime, hold down Command+Option+P+R

| improve this answer | |
  • I just nuked the plist files and rebooted and so far so good. It's hardly a proper fix but it works so it'll do. – atlaz Mar 25 '16 at 12:53
  • Actually, it didn't really stay fixed. When it becomes an issue I can just disable and re-enable bluetooth but this still feels like a "hack" and not terribly scientific. – atlaz Jan 13 '17 at 11:37
8

This "fixed" it for me:

I noticed cfprefsd was hammering the disk - so I used fs_usage to track what it was writing:

  1. Open Activity Moniter, get the PID of cfprefsd
  2. Open Terminal, sudo fs_usage pid <PID>.

    I saw my bluetooth preferences file was getting smashed.

  3. So I disabled bluetooth and cfprefsd.

    CPU usage dropped instantly to negligible levels.

I realise this is not fixing the root problem, but this made my previously unusable macbook air usable again, so I thought others might appreciate it.

| improve this answer | |
3

OK, I just saw the same symptoms on a recently updated MacBook Pro 13" (2015 edition so the latest hardware). I updated to El Capitan and sometime soon after started noticing the slowness issue. I had noticed a cfprefs process hogging CPU but not enough to be causing the severe performance issues I was seeing (keyboard non responsive, etc.)

Turning off bluetooth indeed solved the problem IMMEDIATELY so I think you've found your link. Instead of leaving it off I turned it back on, deleted the one device profile that was connected (an external trackpad) and then re-paired. So far so good; not sure what the "actual" issue was but if this resolves it long-term then I think it's a reasonable workaround.

| improve this answer | |
0

The same happened to me just now. Turned of Bluetooth completely and then the process disappeared.

Running MacBook with El Capitan and latest updates.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.