I recently was forced to destroy everything in the ~/Library/Keychains folder on my Mac (we're using Active Directory users and I've always had keychain troubles when it's time to change the password). I've done this plenty of times before.

However this time, Chrome is no longer saving passwords at all. It still prompts me if I want to save them and occasionally autofills a name (though I suspect that's Mac OS rather than Chrome).

I've already checked and both boxes under "Passwords and Forms" are checked in settings. There are no sites listed under "Manage Passwords." I've also checked to make sure both the Local Items and Login Items keychains are unlocked in Keychain Access.

Any ideas?

4 Answers 4


I had the same issue when my IT folks at work nuked my keychain. I uninstalled and installed chrome following the steps here.

  1. Go to ~/<username>/Library folder.
  2. Delete Google folder from ~/Library/Application Support.
  3. Delete below folders from ~/Library/Caches
    enter image description here
  4. Delete ~/Library/Google folder

Make sure you’ve shut down Chrome while performing this action and then either move the folder to the trash or rename it to something like backup. Chrome and then start Chrome up again.

This will fresh start your Google Chrome.

  • Worked like a charm. Thank you kindly! (I seriously should have thought of this myself. It's basic program reset 101 for Mac)
    – ghostof101
    Dec 15, 2015 at 16:28
  • 1
    By these process, you will lost all stored data on your browser, be careful and save them before you removed them Jan 15, 2017 at 6:45
  • 1
    Deleting the Google Drive folders is not necessary. May 1, 2017 at 20:29
  • @Fa.Shapouri which is why you sign into Chrome to save it to the cloud and then import back....you might need another computer though.
    – eco
    Oct 2, 2018 at 16:18
  • 3
    You don't have to delete everything, you only need to quit Chrome completely, then delete "Login Data" and "Login Data-journal" from ~/Library/Application Support/Google/Chrome/Profile X/ . If you have a lot of profiles you can do this with a one liner: find ~/Library/"Application Support"/Google/Chrome/ -type f -name "Login Data*" -delete Jan 25, 2019 at 20:39

An important addition to this comprehensive answer. This will only work if you sign out of your Google account in Chrome. I tried this method several times and it wasn't until I signed out of Chrome, then deleted all the cached items and the Google folder in the Library folder that my passwords were restored.

Also, another tip (as osx has been updated).
To view the Library folder, when in
the User folder click on -> Show View Options -> There is a check box for Show Library Folder

You can also choose to show this as a default setting if required.


I had the same issue after IT nuked my Keychains. I did not need to uninstall Chrome or delete folders manually. A variation of this answer seems to work reliably.

Essentially, it seems that it is sufficient to nuke the specific user profile, rather than the entire Chrome installation. BTW, chrome://version/ reports 59.

  • Still works, in Chrome 65.
    – Leo
    Mar 18, 2018 at 20:44

I also had to delete my Mac keychain, and then Google Chrome would ask to save passwords but they would be gone every time I restarted Chrome- using OSX El Capitan... The above didn't work for me, but what DID work for me- go to Chrome-->Settings-->Advanced Settings-->Click on "Reset Settings". Restart Chrome, and- they saved!

  • Can down-voters PLEASE comment why they down-vote if it is not immediately obvious. I don't think this answer is necessarily wrong so I'd like to know why.
    – HankCa
    Aug 26, 2016 at 11:03
  • It didn't work. I had to not only use Gopi's answer above, but I also had to go into Keychain Access and delete any Google related application passwords as well.
    – Yinzara
    Jan 30, 2017 at 23:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .