0

I have generated an OS using the Yocto Project, with Linux kernel version 3.14. I have tried several methods to boot this OS from VMware Fusion, all with seemingly-identical results, where the process hangs after Switched to clocksource refined-jiffies. I have removed the VM's USB controller. Here's the relevant part of the message log that I see:

Waiting for root device /dev/hda2...
Clocksource tsc unstable (delta = 863336102 ns)
Switched to clocksource refined-jiffies

How can it be fixed?

1

As it turns out, I was so focused on the two lines about clocksources that I missed the crucial line: Waiting for root device /dev/hda2...; my hard drive was not being recognized because my OS image was configured to use IDE. Within VMware Fusion I had missed that my HD bus type was configured to SCSI. I was able to fix this by navigating to VM settings->Startup Disk->Advanced options->Bus type, and set to IDE.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.