7

I get a red bar when trying to install windows 7 DVD, and it freezes.

I read here https://social.technet.microsoft.com/Forums/windows/en-US/aee2b86b-ab1d-409a-b8ca-e0f6a4c90b3c/windows-7-pro-installation-media-stalling-at-startup-screen?forum=w7itproinstall to turn off secure boot. But I have. (if secure boot is on then it doesn't get that far as booting the DVD, it says "EFI DVD/CDROM ... has been blocked by the current security policy". So I have turned off secure boot).

The Win7 DVD (I made with the Win7 download tool), it seems to boot whether the motherboard firmware is set to legacy, or set to UEFI.. Though when setting the motherboard firmware to Legacy I get the ACPI BSOD error like the BSOD in this question https://superuser.com/questions/1005972/error-with-winpe-the-bios-in-this-system-is-not-fully-acpi-compliant. When set to UEFI I get the red bar. (I am talking here about a Win7 DVD not a WinPE one but the BSOD in that superuser question has the same BSOD).

Laptop is IBM Lenovo B50 30 Model 80 ES

BTW. I have a Win7 USB I made with rufus some time back. That one isn't recognized in the "BIOS" when the "BIOS" is set to UEFI.. And when set to legacy it is recognized and boots but gives the ACPI BSOD error. I would try http://www.eightforums.com/tutorials/15458-uefi-bootable-usb-flash-drive-create-windows.html to create a Win7 UEFI USB but I don't have a spare USB at the moment to test that with. So right now I am just trying to get it to work with DVD.

Interestingly.. an old Macrium USB had the ACPI BSOD (as mentioned in this question Error with WinPE "The BIOS in this system is not fully ACPI compliant" But a newer Macrium whose rescue USB is based on WinPE 10, doesn't have that problem. So it should be possible for a MS Win7 DVD to be updated such that it doesn't have the ACPI BSOD issue.

enter image description here

ADDED 1

I have tried removing partitions by booting a partition wizard dvd. I still get the same symptoms from the Win 7 DVD.

Added 2

As requested, here are pics of the GUI for the motherboard hardware(i'll try not to say BIOS). I'll include a pic of the BSOD too which appears when booting the motherboard firmware set to legacy mode.

In the boot tab, choosing UEFI, causes the security tab to have the secure boot option which can be enabled or disabled.

The exit tab has an option "os optimized defaults" but whether set to win8 or other os, I get the same errors. The BSOD when set to legacy. The red bar when set to UEFI.

And I don't think setting SATA between AHCI and Compatible, makes any difference to the symptoms. (not that it should).

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

Below is the BSOD that occurs when choosing Legacy mode

enter image description here

Below is the message about secure boot.. if I choose UEFI thus getting the option of secure mode enabled/disabled, and choosing Enabled. It won't get as far as booting off the DVD.

enter image description here

And the main error screen i've shown you earlier.. The red bar while the 'starting windows' image/text appears. That's UEFI with secure mode disabled. No image below because it's above , it's the first picture in the post. Really the only two relevant pics are the red bar one and the BSOD one. The load of UEFI pics were requested though.

further info

As another thing to try. I building a Win PE 10 USB by making a macrium usb and using it as a PE for Win7. By making a Win7 directory on it and copying the contents of a Win7 CD onto it, and running win7 setup. It got quite far into the setup, I got this like this screen

enter image description here

it expanded things to 100%, then at some point restarted.. as it should..

but when it restarted, then it said "starting windows" and it hit a red bar again.

enter image description here

I have often found that when it says starting windows and the red dot appears as if a coloured animated logo is about to appear, then I get the red bar too at the top.. So it looks a bit like a graphics issue but there's no vga or graphics option to change in the BIOS.

So to summarize findings so far

*Booting from 64bit Win7 DVD

Can boot Win7 UEFI(it seems), or Legacy

With UEFI, I get the red bar, it doesn't get far. With legacy I get BSOD

*Booting from 64bit Win7 USB

Cannot be seen as EFI.

With legacy, BSOD

It doesn't get far.

*Booting from USB, with WinPE 10 with a win7 folder and the contents of a win7 dvd in there.

UEFI, it getes an installing windows screen, restarts (probably to complete installation), but then gets the red bar.

Legacy, BSOD

Added

I have updated the BIOS. I don't know why but i'm finding now that my Win 7 64bit DVD (and no doubt a 32bit one too) isn't recognized in EFI. Not surprisingly it doesn't have efi\boot\bootx64 file that i've noticed is necessary on USBs too. maybe it's necessary on DVD too, though that doesn't explain why previously, I was finding a win 7 DVD was recognized as EFI . I don't know if that's the BIOS update that removed that functionality! Win 10 DVD has efi\boot\bootx64 file and boots fine.

added- chat link http://chat.stackexchange.com/rooms/32554/discussion-between-barlop-and-magicandre1981

20
  • I had a similar issue with my Dell laptop: superuser.com/a/583227/174557 look for such an VGA ROM setting Dec 1 '15 at 5:37
  • My BIOS doesn't have that many options. But choosing Legacy resulted in a BSOD like superuser.com/questions/1005972/… and choosing UEFI resulted in the red bar.
    – barlop
    Dec 1 '15 at 5:52
  • @magicandre1981 I already described the options so I don't know what you think you are going to see, but as you wish... and while in that comment I used the word BIOS, it's technically incorrect and a slip on my part.. As you perhaps know, it's not really a BIOS is it. As I understand it, It's UEFI set to either UEFI mode or legacy mode.. It's motherboard firmware / the GUI for it... Not a BIOS these days. So probably not a good idea for you to call it BIOS 'cos that's wrong terminology as I understand it.
    – barlop
    Dec 1 '15 at 6:40
  • hm, this looks like you cant change it. Without the VGA ROM you see the hang as Win7 doesn't support UEFI Graphic boot: support.microsoft.com/en-us/kb/2828074 Dec 1 '15 at 18:45
  • @magicandre1981 The computer does support legacy though. (and btw with legacy mode it gives a BSOD).
    – barlop
    Dec 2 '15 at 0:00
10
+500

Windows 7 doesn't support the new UEFI GOP (Graphics Output Protocol) and requires VGA option ROM (BIOS interrupt 10 (INT 10H)). Win8/10 supports GOP and reads the UEFI Logo and displays it during boot for a smoother boot. And it seems that your UEFI always turns GOP on and disables VGA, so Win7 can't be used and hangs at Starting Windows with the graphic artifacts.

5
  • Do any systems support both GOP and VGA together? Such that Win7 could use the VGA and ignore the GOP? And is it purely a motherboard firmware issue, such that if a UEFI manufacturer updated the UEFI then they could enable VGA and thus enable Win7 to be installed?
    – barlop
    Sep 19 '16 at 4:34
  • 1
    It seems that the medion E6239 has a firmware option for this. In the UEFI there is an OS setting which can be toggled between win7 and win8. No explanation what it does, no in EFI help, nothing in the manual. But setting it to win7 solved this problem.
    – Hennes
    Sep 19 '16 at 12:00
  • 2
    my UEFI in my Dell Laptop has an option to enable the VGA option ROM (superuser.com/a/583227/174557), but most ones don't support it. They use GOP in UEFI (Win8) mode and VGA in legacy/Win7 mode like you saw in your case @Hennes Sep 19 '16 at 15:38
  • @magicandre1981 so if most laptops's UEFIs only run with GOP, and don't support a VGA option ROM option, then most require the UEFI set to legacy to install Win7? Your answer explains a lot though doesn't explain the BSOD in legacy mode, which would be some other issue
    – barlop
    Jul 23 '19 at 22:47
  • Bug Check 0xA5: ACPI_BIOS_ERROR with Error code 0x11 in first parameter means "ACPI failed to load DDB" which is disk database, and in legacy mode, the UEFI hdd partition data can't be read. Jul 24 '19 at 14:04
0
  1. Disable Secure Boot in BIOS/UEFI
  2. Change Boot Mode to Legacy/CSM
  3. Create a Windows Boot Stick with Rufus and select the MBR partition scheme for BIOS or UEFI-CSM
1
  • I think it looks from my question that I tried both all three of those, (disabling secure boot, changing boot mode to legacy/csm, creating the usb stick in rufus with uefi/csm option) but looking at the accepted answer, it looks like there's a fourth setting I need but don't have in my UEFI, which is to set UEFI to GOP, vs setting UEFI to VGA. My UEFI only has it set to GOP. It seems maybe some people might have a UEFI that has an option to enable/disable VGA, and apparently that might be what i'd need in my case..
    – barlop
    Nov 22 '18 at 21:31
-1

This may have been solved and may be different but I had this problem also, but will put my "fix" in case anyone it can help anyone else?

It was solved by going into the BIOS and changing the setting from Win8 64 BIT to other OS (I left UEFI setting as is and didn't change it to legacy support)

2
  • Though bear in mind I wrote "The exit tab has an option "os optimized defaults" but whether set to win8 or other os, I get the same errors. The BSOD when set to legacy. The red bar when set to UEFI." So that option didn't work in my case.
    – barlop
    Jan 31 '17 at 10:10
  • 1
    please state your laptop model, and verify that you were installing windows 7 It must be that your laptop supports the VGA Rom option inherently with "other OS".. in UEFI . Makes me wonder what "other OS" was doing in that laptop I tried that it didn't work.
    – barlop
    Jan 31 '17 at 10:11
-1

I just had the same issue trying to install windows 7 pro. I went back to the Bios and on the 2nd tab I went down to OS Windows 8.1 and selected it and their was an option for Windows 7 I selected that saved and exited and it worked.

John

1
  • these things can be laptop dependent, therefore it'd be helpful if you included the make and model of your laptop in your answer
    – barlop
    Jul 23 '19 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.