1

I am totally new to Linux and installed a Peppermint Partition on my HD. Then I tried to install from Peppermint a live USB, but ended up mounting the image on the hard drive.

Now I have this installation listed among Devices. I have run "mount" and got this line among others:

/dev/sdb on /media/jack/Prova Live type iso9660 (ro,nosuid,nodev,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks2)

How can I delete it? If I run Gparted it shows there is unallocated space only on sdb, but if I click on the icon of the usb installation that I am trying to remove on Devices, a folder opens with directories in it.

I have tried unmount dev/sdb and reboot but the icon and the folder is still there...if I run mount I don't see it at first, but if I click on it from the device menu and then run mount it shows up in the list... Any ideas?

  • Did you use the Peppermint installer, and what did it do? lsblk & blkid & gparted should help identify what's what. sdb looks like the iso on a dvd or usb, it's not your hard drive is it, with no partitions? – Xen2050 Dec 1 '15 at 10:28
  • I used "dd" to mount the image! – Jack Dec 1 '15 at 13:40
  • Good 'ol Data Destroyer, it doesn't really "mount" things, reads & writes just about anything, like turn a HD into a dvd. Doesn't Peppermint have an installer when it runs live? Boot from a usb/dvd and just install to the hard drive... may need new MBR/GPT now though – Xen2050 Dec 1 '15 at 13:47
  • I realize now I made an error in the question, I am not trying to install Peppermint, it is already installed on my HD. What I have tried was install it on a USB to make it live and bootable, but accidentally set the target for the installation on the HDD instead than the USB, and now I cannot remove it. – Jack Dec 1 '15 at 14:15
  • Did you have anything on that drive that you care at all about? – a CVn Dec 1 '15 at 14:21
0

Assuming /dev/sdb is the drive you're trying to "un-iso", it would appear that you've overwritten sdb's old MBR/GPT partition table.

Now gparted may not see any partitions and says it's all unallocated space (that's what mine does when I setup an .iso file as a loop device, and have gparted examine the loop device).

So, start up gparted and examine /dev/sdb, tell it to Create a new Partition Table (MBR/GPT/etc) by:

  • Going to the menu Device -> Create Partition Table and
  • write a new partition table.

The "msdos" type is the old MBR, or "gpt" is the new GPT partition table, use whichever you prefer or google for advice.

After that, make a new partition (or a few, whatever you want).


If you just want to make a bootable live USB, you can use a program like Unetbootin, or Universal USB Installer.

Or I prefer a multiboot USB (even if there's only one .iso to boot) since it doesn't overwrite the whole drive's partition table like plain dd does, and you can use a filesystem like ext3/4 or something more reliable than FAT (FAT USB's tend to erase all their filenames somewhat regularly for me somehow, never a problem on the same USB with ext3).

Instructions can be found in this other A of mine and they're basically:

[As] described here on Arch's Wiki or here on pendrivelinux.com, for many distros you just copy the ISO file onto the usb and edit grub.cfg. Cliff notes instructions are:

  1. Mount the usb
  2. Install grub grub-install --force --no-floppy --boot-directory=/mnt/USB/boot /dev/sdx (replacing x with your actual USB device & /mnt/usb with mounted dir)
  3. Put demo grub.cfg ( http://pendrivelinux.com/downloads/multibootlinux/grub.cfg ) in /mnt/USB/boot/grub and edit to match your iso's

Or see the Ubuntu help on creating & installing from bootable USB's, can the Ubuntu tool Startup Disk Creator, Unetbootin, or plain dd.

And I think you could even make it persistent by adding another partition on the USB just named "casper-rw", similar to these instructions on pendrivelinux.com , but I haven't tested it with a multiboot usb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.