0

Some apps in my PC suddenly gone missing, pinned app icon becomes blank, and worst is that one of the missing one is Store. Others I have noticed are MSN apps, Mail, Calendar, and Photos, any help how to restore them?

UPDATE: Reinstalling via PowerShell with following command doesn't work:

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

It show lots of error. If there is a way to generate log file please tell me.

UPDATE: Found a documentation from Microsoft here and after following it, still it doesn't work but it generates a shorter error information:

Add-AppxPackage : Cannot find path 'C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.2323.4.0_neutral_~_8wekyb3d8bbwe\App At D:\Aprianto Nursetiawan\Desktop\reinstall-preinstalledApps.ps1:35 char:2 + Add-AppxPackage -register $PackagePath -DisableDevelopmentMode + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (C:\Program File...dleManifest.xml:String) [Add-AppxPackage], ItemNotFoundException + FullyQualifiedErrorId : PathNotFound,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

  • Maybe move this question to appropriate site? – Nur Dec 1 '15 at 12:36
  • It is already at the appropriate site. Are you able to use a restore point by chance? Did you run any commands to remove Cortana or do anything that might explain what basically amounts to removing the WindowsApps directory? – Ramhound Dec 1 '15 at 13:03
  • I got a downvote, probably I asked this on a wrong site? Anyway, I removed the Xbox app months ago, and now I want it back, I ran the powershell command to reinstall default Windows 10 apps (the same with UPDATE 1 in my question), but the result is instead of the apps I removed (the Xbox app) to be reinstalled again, it removed some of my apps. including Store. – Nur Dec 2 '15 at 14:38
  • Also system restore probably works, but if possible I don't want to use it since the restore point is several days ago and I have installed GBs of applications and driver since then, unless as last resort. – Nur Dec 2 '15 at 14:40
  • @Ramhound Hey.. I gave up and asked my friend to take care about it, he restored my PC and reinstall everything I needed with his internet connection. So if you would go ahead and answer with system restore solution I'd accept it, thanks. – Nur Dec 4 '15 at 0:52
1

Try resetting the Windows Store Cache:

  1. Go to the Start Screen or the Windows Modern UI screen
  2. Type in WSReset.exe
  3. Click on Run as administrator

enter image description here

  1. Reboot, log in, and test.
  • Hey. Done running WSReset.exe and restarting, but the Store app still missing? Is this procedure also works in Windows 10? – Nur Dec 1 '15 at 13:05
  • It should work in Windows 10. Did you run it as Administrator? Else take a look at this link: thewindowsclub.com/windows-store-app-missing-windows-10 try step 1 till 3. – Smeerpijp Dec 1 '15 at 13:12
  • Yes. I ran it as administrator. I have followed that link, the result is posted in second UPDATE on my question. – Nur Dec 2 '15 at 14:59
  • running that got me to an error message from WSReset.exe: "ms-windows-store:PurgeCaches" With further "info": "The application cannot be started. Try reinstalling the application to fix the problem". And yes, I can read, but where and how do I reinstall it? Via those powershell scripts? Doesn't work :/.. – Yves Schelpe Jul 6 '16 at 6:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.