0

When I attempt to connect to any site that uses an HTTPS connection (e.g. https://www.google.com), I get a 'This Connection is Untrusted' error. I'm using FF 42.0.

I followed the instructions in the The certificate is not trusted because the issuer certificate is unknown section of the "This Connection is Untrusted" error message appears - What to do page--essentially deleting the cert8.db file located in my Firefox profile folder (when FF was closed, BTW).

I restarted FF, but the problem persists.

Chrome (46.0.2490.86 m) and IE (10.0.9200.17519CO) work as expected.

What am I missing?

** edit **

For some reason, the '' option is presented for https://www.google.com, so I'm posting the certificate for https://www.yahoo.com instead (same error).

General:

general tab

Details:

details tab

  • Are you able to post the details of the certificate firefox is trying to load? On the page that says 'This connection is untrusted', click on 'I understand the risks' and the 'add exception' (DO NOT ACTUALLY ADD THE EXCEPTION). One the popup screen shows you can view the certificate before adding the exception. It will show the certificate chain and details on what certificate is loading. – tyelford Dec 1 '15 at 23:49
  • I don't know if it is relevant, but I'm having similar issues with RubyGems. – Craig Dec 1 '15 at 23:59
1

Looks like you have some bad certificates in your Firefox store. Here is the certificates from yahoo.com and google.com for my browser. You'll see that they are from a trusted certificate authority -- VeriSign and GeoTrust, where yours is from SHC Issuing CA.

The only other thing that might be happening is SSL inspection if your computer is on a corporate network and they have some kind of appliance that does SSL Inspection. But this is unlikely since it works fine with IE and Chrome.

Yahoo Certificate

enter image description here

Google Certificate

enter image description here

Have a look at this article from Firefox on how to fix the issue. https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

I would be trying to delete the cert8.db file:

The file cert8.db in your profile folder may have become corrupted. Delete this file while Firefox is closed.

Open your profile folder:

Click the menu button, click help and select Troubleshooting Information. The Troubleshooting Information tab will open.
Under the Application Basics section, click on Show Folder. A window with your profile files will open.
Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

Click the menu button and then click Exit.
Click on the file named cert8.db.
Press Delete.
Restart Firefox.
cert8.db will be recreated when you restart Firefox. This is normal.

Failing that I would be uninstalling and reinstalling Firefox.

Also do a virus scan to check if something bad has infected your browser, just for piece of mind.

  • I have already removed the cert8.db file and restarted. I've also tried removing FF and all of its components. Same results. I am on a corporate network. – Craig Dec 2 '15 at 0:25
  • 1
    If you are on a corporate network I would be asking your IT department. They probably have per-installed, or pushed out certificates for Chrome and IE but not FireFox. I know from experience that it is a lot easier to manage these settings for Chrome and IE, where FireFox can be more challenging. – tyelford Dec 2 '15 at 0:31
0

Just try it by changing connection settings in option->advanced->network->settings->auto-detect,perhaps it will work for you.

  • 1
    Why will that work in this instance? The browser will still be using the locally installed certificates – Burgi May 31 '16 at 7:39
  • Welcome to Super User! While this may answer the question, it would be a better answer if you could provide some explanation why it does so. – DavidPostill May 31 '16 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.