0

TL;DR:

For some reason hot plugging my Thunderbolt dock is not working correctly on my new laptop. I am trying to determine if I've overlooked a troubleshooting step.

Problem:

If the dock is unplugged after the system has already booted then my USB devices (mouse & keyboard) will not reconnect when the dock is reconnected. Thunderbolt monitor reconnects, but not USB. No power is provided to the keyboard or mouse - keyboard lights do not illuminate & optical sensor on the mouse stays dark. This is resolved with a reboot, but the problem persists.

Hardware / Software:

  • Dell Precision M3800
  • BIOS A09 (previously upgraded to A10 before motherboard replacement)
  • Windows 10 (direct upgrade from Windows 7 64 Bit Professional )
  • Belkin Thunderbolt 2 Express Dock HD
  • Thunderbolt (TM) Controller - 157D
    • Device manager hardware ID "PCI\VEN_8086&DEV_157D&SUBSYS_11112222&REV_00"
    • This is an Intel hardware ID (fitting as Intel makes Thunderbolt)
  • GRUB bootloader
    • Kali Linux on second hard drive partition

Attempted fixes: (None of these solved the problem)

  • All Intel Chipset drivers reinstalled from Dell's website via their tech support's recommendation
  • Driver update on Thunderbolt controller yields "Software for your device is up to date"
  • "Fresco logic USB3.0 host controller" reinstalled
  • Upgraded original OS from Windows 7 to Windows 10
  • Upgraded system BIOS from A09 to A10
  • Had Belkin directly replace the docking station with a new one
  • Had Dell directly replace the system motherboard
    • The new board has the A09 BIOS
  • Stopped and started Thunderbolt (TM) service
  • Booted into Safe mode
    • Thunderbolt works on boot but the thunderbolt service cannot run in safe mode
    • Hot plugging fails to work correctly in safe mode
  • All Thunderbolt devices involved have been authorized in the "Thunderbolt TM Software" and set to "Always Connect"

Other Notes:

  • An identical Precision M3800 and Belkin dock were ordered at the same time as my own
    • This other laptop does not have the same problems mine does with hot plugging
    • This other "working" laptop has been used with both docks w/o problems hot plugging
    • The "non-working" laptop has the same problems hot plugging with both docks
    • The working laptop has Windows 10 loaded onto it - it was also upgraded from x64 7 Pro
    • The working laptop does not have GRUB or a second OS installed
  • Cannot locate drivers for the "Thunderbolt 157D controller" on Intel's website.
    • It is possible that this is a rebadged controller they are already manufacturing; complete dearth of information.

Last Thoughts:

  • Is there anything obvious I am overlooking?
  • Is there some problem with hot plugging when GRUB is installed or a second OS is on a system?
  • Are there any pieces of system software that typically interfere with hot plugging thunderbolt devices?
  • With this description would a fresh OS reinstall likely fix the issue?

Apologies for the length of this post; thus far commercial tech support has been limited and time consuming. I am hopeful that someone in the community may already be familiar with this issue.

  • What precisely do you mean by "previously upgraded A10". I can't tell if you are running A9 or A10 based on that statement. You should clarify that statement, because saying something was previously upgraded to a newer revision firmware, after you indicated you using an previous revision firmware is confusing. I assume both docks a work on the laptop that does have this problem. Do both laptops run multiple operating systems, if they do, then clearly that isn't the case. I have other questions, but I require answers, before I will ask them. – Ramhound Dec 2 '15 at 14:48
  • If you have identical machines you should be able to pull the HDD out of one, boot it on the other, to determine if the problem follows the installation of Windows. – Ramhound Dec 2 '15 at 14:51
  • @Ramhound Thank you for the suggestion! We actually just brain stormed that idea as well - great minds! And the laptop motherboard was switched last night; it is back to A09. I will change my initial question. – Shrout1 Dec 2 '15 at 15:36
  • my original comment has a couple typos. Its clear you understand what i was asking so I am not worried. In case that isn't the case I wanted to know if both docks worked on the "working" laptop or not. – Ramhound Dec 2 '15 at 15:38
  • @Ramhound Yes both docks work on the "working" laptop; changed my initial question to clarify. – Shrout1 Dec 2 '15 at 15:39
0

This is barely an answer, but re-imaging the system with a working OS fixed the problem. I have no idea what the ultimate problem was, but clearly it was something to do with software. After the re-image I also reinstalled GRUB and the second operating system. This did not prevent hotplugging from working.

What a pain...

0

Exact same issue symptoms here except that I am still hanging on to Windows 7. What I did was:

  1. Disconnect the device from the computer
  2. Go into the device manager
  3. Go to the properties of the affected device,
  4. Look under the Driver tab and
  5. Note the Driver Version, then
  6. Look under the the Details tab and
  7. Get its Device class GUID, let's call this {XXXXXXXXXXX}, then
  8. Go to your registry editor Start->regedt32,
  9. Back up the registry in case you mess something up.
  10. Look under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{XXXXXXXXXXX}
  11. Find each item in there that refers to the same device (I did this by driver version) and delete its folder within {XXXXXXXXXXX}.
  12. Reboot

That seemed to work for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.