8

I have a Ubuntu 14.04 server that exposes a samba share to Windows machine. When I connect to the share and create files with notepad, permissions are respected and files don't become executable. However when I use Visual Studio to edit the files, every time I save them, executable bit is flipped on. Some googling uncovered a thread that links wb file open mode with archive attribute on windows and therefore execute bit on Linux.

However given my config, this should not be the case.

    read only = no
    acl allow execute always = no
    acl map full contorl = False
    map archive = no
    map system = no
    map hidden = no
    create mask = 0664
    force create mode = 0664
    directory mask = 02775
    force directory mask = 02775
    inherit permissions = False

If at all possible I would like to configure samba so that it would just leave the execute permission alone - period.

2
  • 1
    I have a similar problem. Don't have a solution, but just in case: you have a typo in your acl map full contorl setting. – Alexander Ljungberg Mar 12 '20 at 18:08
  • Try deleting acl allow execute always = no – Zoran Jankov Oct 22 '20 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.