Everytime I start up Teamspeak 3 client, I get Windows UAC pop up and to be honest it's finally annoyed me to the point I'm going to try and do something about it!

After reading up on teamspeak it might have something to do with installing the program for all users, which will then use each user's virtualstore to actually run the program and I'm thinking that is why I get the UAC notification.

Can anyone confirm this is/isn't the case? If this isn't the case, how can I make it so that I don't get UAC notifications for the launch of this specific program?

OS: Windows 10 x64 Installed on OS/main drive, in Program Files.

  • Teamspeak 3 shouldn't need Administrator permission, what feature does not work, if its not elevated?
    – Ramhound
    Dec 2, 2015 at 20:04
  • It doesn't launch unless I give it access.
    – Stormie
    Dec 2, 2015 at 20:07

2 Answers 2


The general approach to get rid of the UAC is using the Microsoft Application Compatibility Toolkit.

  1. Download and install the Microsoft Application Compatibility Toolkit.
  2. Start the appropriate version 32bit or 64bit - depending on the application to modify.
  3. Select the "New database" (or reopen an existing database, if you are adding another application tweak) and right click -> "Create New" -> "Application Fix".
  4. Enter name, vendor and select the executable [continue]
  5. Skip the compatibility modes [continue]
  6. Select the single compatibility fix: "ForceAdminAccess" [continue]
  7. uncheck all boxes but keep "COMPANY_NAME" and "PRODUCT_NAME" (otherwise you have to create a new patch for every version) [continue]
  8. select the database and save it
  9. right click on the database and install it.

If this does not work, you may also try adding the compatibility mode "RunAsAdmin".

  • My issue is that I don't want notifications that freeze my computer/dim the screen and all of that while launching this application. I've now found a fix though. :)
    – Stormie
    Dec 2, 2015 at 20:24

If a Windows program is installed in the default Windows program directory and UAC is enabled, it is write-protected. The virtualstore was made to support legacy apps that must put their data into the program directory. If a program attempts to write something into it's program directory, Windows redirects the write operation and the files are written to the virtualstore directory instead. Windows then merges the two directories, so the user doesn't notice that and thinks it is all one directory

To fix this I reinstalled Teamspeak and installed it outside of the Program Files directory, this eliminates the problem of needing access to edit files in the virtualspace and therefore stops the UAC notification!

  • That’s still not normal. TeamSpeak 3 is modern software. It does not write settings to the installation directory.
    – Daniel B
    Dec 2, 2015 at 20:39
  • Edited answer to include my previous comment
    – Stormie
    Dec 3, 2015 at 8:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .