0

Ubuntu 15.04 shows the following error when I try to boot. This happened after a direct upgrade from 14.04.

Target filesystem doesn't have requested /sbin/init.

/bin/sh: 0: Can't open splash

[ 5.668912] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00

1 Answer 1

1

You will have to:

  1. Boot from the installation medium (a USB? A CD?).

  2. Open the terminal, and determine the partition on which your Linux system is hosted. Issue the command

    sudo parted
    

    and then, when the prompt appears,type p. This diplays the disk partition table. Your partition is neither the swap nor an the extended partition (if you have it, you might not have one). The partition you are interested in is the one with the boot flag. Let us assume it is /dev/sda1. Quit parted by menas of q, then

  3. issue the command

    sudo fsck /dev/sda1
    

    When done, give the command

    sudo shutdown -h now
    
  4. Now remove the USB stick, and you should be able to boot normally.

1
  • I tried that but nothing happened still got the same error after booting...thanks for the help. Dec 3, 2015 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.