0

I upgraded to Windows 10 on my laptop. I have opened SQL Server Management Studio, but it can't connect to the server.

I have looked at a few other questions, but nothing seems to work. I get the same error message as in this post

I also went to Control Panel > Admin Tools > Services and made sure SQL Server Browser is running.

Not sure what to do.

migrated from stackoverflow.com Dec 3 '15 at 20:10

This question came from our site for professional and enthusiast programmers.

  • What does this have to do with C# or programming in general? – Ron Beyer Dec 3 '15 at 19:30
  • sorry thats a mistake – mHelpMe Dec 3 '15 at 19:31
  • 1
    Anything to do with a firewall or closed ports? Try disabling your firewall for an attempt. – Marleen Schilt Dec 3 '15 at 19:42
  • I have the standard windows 10 firewall. I switched it but didn't fix the issue – mHelpMe Dec 4 '15 at 9:56
0

Have you checked the shared memory in SQL Server protocols? If it is disabled, you will not be able to connect to SQL Server in Windows 10.

On contrary, in Windows 7, 8 and 8.1 enabling the shared memory was often causing the same effect, so it is by the rule that it is often disabled. After upgrading to Windows 10 you might hit the issue as now it is required to be enabled... not sure why MSFT made this mess, but I have seen this issue quite often after upgrading to Windows 10

Run SQL Server Configuration Manager and then navigate to SQL Server Native Client Configuration

Check Shared Memory and if disabled, enable it

Try to connect SQL Server again

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.