5

I recently upgraded my computer from using onboard graphics to a GTX 960 (GV-N960OC-4GD).

I previously had a dual monitor setup, with my primary monitor (SyncMaster2233sw) using a DVI cable and the secondary monitor (Syncmaster 173v) using a VGA cable. I purchased a DVI to VGA adapter to connect the secondary monitor, and while it detects the monitor the screen remains black as if it is in standby mode.

Screenshot

I can even move windows and my mouse onto the second monitor, however it obviously just disappears from sight. I've also tried switching the cables to see if it was a faulty port, however my primary monitor works in both, just the secondary that remains black.

Any help would be much appreciated!

NVIDIA Control Panel:

enter image description here

GPU drivers:

enter image description here

UPDATE: The problem was just a faulty VGA-to-DVI adapter. That's what I get for buying it off eBay I guess.

UPDATE 2: It turns out that I needed a DVI-I adapter as my secondary screen apparently only accepts analogue output whereas I was using a DVI-D (digital) adapter.

  • Have you tried using the nvidia controlpanel to do the dual monitor setup. – JelloDude Dec 4 '15 at 8:12
  • 1
    @JelloDude Yes, it says it's detected so I'm not really sure what else I can do. See here: puu.sh/lIRpK.png – WabiSabi Dec 4 '15 at 8:14
  • 1
    @VlastimilOvčáčík I assume I am as under Monitors they are both listed as "Generic PnP monitor". I have attempted to install the driver for the secondary secondary monitor which I found online, however I don't think it is supported on windows 7, as I get a it is a very old monitor and I get this error the second I try and open it: puu.sh/lITdO.jpg – WabiSabi Dec 4 '15 at 9:36
  • 1
    @VlastimilOvčáčík I'm fairly certain it is running off the graphics card driver as I installed the drivers from the disc and updated everything. Here's what comes up under device manager: puu.sh/lIUTR.png – WabiSabi Dec 4 '15 at 9:58
  • 1
    I just noticed that your card has a "1" and a "2" next to the DVI outputs. I have similar markings on my own card and that one only allows me to use ports from "set 1" or from "set 2". I have problem finding information on that on Gigabytes website though. I also do not see a dotted line, which I do see on the 960. (i.stack.imgur.com/kHXjb.png) – Hennes Dec 4 '15 at 11:19
1

Assuming that you are using a Windows machine, try the following:

  1. See if the connections are correct.
  2. Press Windows key + P.
  3. Select duplicate or extend options.
  4. Even now if the screen does not appear then check if you have powered on the 2nd monitor.
0

It's weird, that the second monitor is not listed in the device manager.

Check if the current screen settings for your second monitor are actually supported by it (screen resolution, refresh rate).

Then try to swap monitors (change their order of 1 and 2 internally in Windows only) and see, if the second one is actually responding.

If that doesn't help, change their connections on your PC - maybe the second DVI-out out is somehow ... "broken".

If the second monitor still stays black - get a new one ;-)

Sometimes my second monitor isn't available too and flickrs (?) all around. Then i just turn it off and on again and then it is recognized by Windows.

But there might also be a wrong setting that prevents outputting video information on the second DVI-out. You might double check your setting within nVidia Control Panel and the (usually) built-in Intel Graphics Control panel or whatever.

  • Oh sorry that's my bad, I'd unplugged the screen to test it in the other port and forgot to plug it back in. They do both come up though as "Generic PnP Monitor". I know the screen itself isn't broken because it was working with on-board graphics from the motherboard before I installed the new graphics card. – WabiSabi Dec 4 '15 at 12:26
  • The check your graphic card settings. Oviously there's something wrong. Not sure, if there might be a "hardware setting" on the card itself, to support both DVI-outs, like a jumper or anything. – rob_st Dec 4 '15 at 12:30
0

There exist "video range extender" solutions which connect signals directly to a different cable style, without changing the signal format. This is useful if, for example, you have long VGA cables permanently installed inside the walls of your room, because you can use the existing cable to carry DVI or HDMI data. But you must use the corresponding adapter to change the signal back to its original connector type, that matches the signal encoding. You can't expect to connect directly to a device supporting the new connector format, since it also expects a different signal encoding.

While a DVI-I to VGA connector is also passive (no re-encoding), use of the analog pins in the DVI-I connector signal to the video source to generate VGA (analog) signalling instead of DVI, so that the monitor receives a real VGA signal as it expects.

Another thing to try if whether your second monitor has an "input" or "source" button. If your monitor is displaying from DVI in but you've hooked up its VGA cable, then you would not get any picture.

0

I just encountered the same problem. Found the solution which is to right click on the 2nd monitor -> Properties -> Under the Adapter tab -> List All Modes and change it to 16 bit.

0

Wow, all I did was press the monitor menu buttons on the physical monitor and it magically starting displaying and no longer blank.

I was about to try and reset to factory defaults as I read elsewhere on the web might work, but now... I don't need to.

Hope this helps someone :).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.